Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Your Shopping Cart is empty!


sekz

Recommended Posts

Hi. I download ans installed osCommerce without problems, but when I tested I get a really bad result when I try to buy anything. I choose a product from the shop, I click on "buy me" button and the message "Your Shopping Cart is Empty" appears and the only button that appear in that window is the "continue" button, and when I click it I go back to the homepage and I can't buy anything.

Please help me... Sorry for bad english.

 

H?lio "Sekz" Lagoela :)

Link to comment
Share on other sites

Firstly, if you tried to play with, or even look at the code you may have introduced errors. These will be your problem to sort out. The best thing to do under these circumstances is re-install the program becuase it does work as distributed.

 

Secondly, Have you changed anything in admin? I'm more inclined to think the answer lies in my first comment.

 

Regards

Link to comment
Share on other sites

Actually installing was really easy and all went well...

I've made a search on this subject at the forum and see that I'm not the only one to have this problem. It seems that the problem is solved by changing this setting: register_globals = On . I don't seem to find this option anywhere. I read that I have to restart Apache too but I'm using a tripod account and don't know if I can restart it. :(

 

Please help me if you can.

 

H?lio "Sekz" Lagoela

 

Sorry for bad english

Link to comment
Share on other sites

Register_globals is st to off so it must be set on at the server end.

 

Register_globals_on is located in the server's php.ini file too which you have no access. If the lack of Register_globals_on is indeed the case, you can modify the htaccess file and override your server setting.

 

Anyway, your .htaccess file is in the /catalog folder.

 

Just uncomment the secondlast line and try that:

 

php_value register_globals 1

 

Also try replacing 1 with 0 if that doesn't work although I think 1 would be on as in a light switch.

 

I'm not sure about the security issues but they should be minimal.

Link to comment
Share on other sites

I use notepad and dreamweaver. I've a little more about it and I discovered that the problem is related wih the php platform :(

My webhosting sp (tripod/lycos) didn't fix that! :(

I'm trying to find another sp... You know of some... just leava them here.

 

Thx for all the help. :lol:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...