Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Download error - Please help !!


Darren Cann

Recommended Posts

I have installed the latest OSCommerce and all seems to work fine.

When I purchase a product and receive a download link I get,

 

Forbidden

You don't have permission to access /catalog/pub/.xkhcgcokwrvgpigqxrzh/unreal.zip on this server.

 

I'm pretty sure I have everything in the right place !!!

 

Any help would be greatly received.

 

Thanks

 

Darren

Link to comment
Share on other sites

Check your catalog/includes/configure.php file for

 

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

Also, make sure that both of these paths are fully readable and writable 777.

 

Use the chmod command in a command window, or set permissions via your control panel, or use a FTP client that provides for the chmod command. Lots of posts here at the forum that talk about how to set the permissions.

 

HTH

Tom

Link to comment
Share on other sites

All the permissions are fine and all the config looks good.

 

I still get the "Forbidden You don't have permission to access to xxxx "

error comming up. I've tried recreating the site and reinstalling the software.

 

This is driving me up the wall.

I want to use this software but this is really holding me up !!

 

Anymore suggestions, please help !!!!!!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...