Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

NEED HELP !!


sinryder

Recommended Posts

hello guys , i am using easy populate contributions to upload the items to my store and this is the error i am getting

 

15MG6370-Burgundy... ERROR! - Too many characters in the model number.

12 is the maximum on a standard OSC install.

Your maximum product_model length is set to 12

You can either shorten your model numbers or increase the size of the field in the database.

 

i went in PhPMyadmin then selected my database and went in products in there i have changed setting for all the options : below is the copy of what i have changed

 

Field Type Attributes Null Default Extra Action

products_id int(20) No auto_increment

products_quantity int(4) No 0

products_model varchar(20) Yes NULL

 

 

also i have 3 database in phpmyadmin

 

mghatworld_osc1

mghatworld_osc2

mghatworld_osc3

 

i chagned the setting on all 3 , just to be on the safe side but

 

product id and product_ model i have changed it to 20 but its still saying 12 is my maximua product model.

 

any help is greatly appreciated.

thx

Link to comment
Share on other sites

I don't use Easy Populate yet but I was looking through the release history while researching it and came across the following from the 1.2 release:

 

20 Nov 2002 - Easy Populate 1.2  Author: Tim Wasson

<SNIP>

2. If you had a product_model that was too long, it would try to insert it into the database, causing data screwups. The code now checks to see if the length of the product_model is too long, if it is it complains. If you have modified OSC to have longer product_models (like I have!), then you will need to change the variable $modelsize in the source code near the top of easypopulate.php.

 

Hope this helps! (or at least points you in the right direction)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...