Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sids problem


Guest

Recommended Posts

I have the new version of osc with Prevent Spider Session in admin. I have a robots.txt file that is supposed to be working properly to prevent spider on certain pages.

 

The session id thing doesn't seem to be working. I have cookies enabled in my browser, but still get the session id in the links. When I see what the search engine have they all have the osCsid= in the links. I've had numerous visits from customers through these types of link coming through the SE's.

 

Search Engine Spider Simulator Results

Status 200 (return error code 0)

Spider url http://www.katlynskornergifts.com

User Agent Mozilla/4.0 (compatible; MSIE 5.0; Windows NT 5.0) 68.18.39.59

Referrer http://www.searchengineworld.com/cgi-bin/sim_spider.cgi

--------------------------------------------------------------------------------

Spidered Links

= spider this link with current settings.

= keyword density analyze this link.

Link

http://www.katlynskornergifts.com/

http://www.katlynskornergifts.com/index.php?osCsid=b6db7e54

24cf11a60be766afd754e223

http://www.katlynskornergifts.com/index.php?osCsid=b6db7e54

24cf11a60be766afd754e223

http://www.katlynskornergifts.com/products_new.php?osCsid=b

6db7e5424cf11a60be766afd754e223

http://www.katlynskornergifts.com/products_all.php?osCsid=b

6db7e5424cf11a60be766afd754e223

http://www.katlynskornergifts.com/featured_products.php?osC

sid=b6db7e5424cf11a60be766afd754e223

http://www.katlynskornergifts.com/about_us.php?osCsid=b6db7

e5424cf11a60be766afd754e223

 

 

This is my set up in Admin:

Sessions

Session Directory /tmp

Force Cookie Use False

Check SSL Session ID False

Check User Agent False

Check IP Address False

Prevent Spider Sessions True

Recreate Session True

 

I'm at a loss and don't know how to fix this or where to even look. I've been all over the forum and through my code. I haven't the foggiest idea where to start and what to do.

 

Can someone please help on this?

 

Thanks so much.

Link to comment
Share on other sites

Hi Eric,

 

THANK YOU for your reply.

 

How do I tell that? I just performed that check through www.searchengineworld.com and that is the result, so I think it's still picking them up. Why would that show them, if it's not getting them like that?

 

I am confused about the whole sid issue.

 

Thanks again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...