Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Easy populate problem

Recommended Posts

for some reason when i upload products using EP i get this error


No products_model field in record. This line was not imported


but i dont get it, i am inserting a model number which it inserts fine, also when i upload it is setting all of the prices to 0. any ideas on where im going wrong?



"because it'll hurt more"- the greatest film of all time?

Link to comment
Share on other sites

I would ignore the products_model thingy - we have uploaded over 6000 products, had that message every time, the site has been active for nearly a year now, and not once has anybody felt the need to say"hey we have no product number - whats going on???" . Not sure what it is, what it does, but it obviously aint that important! BTW every product in our store has a unique 6 digit code, that aint the product_number, 'cos that uploads and works fine.....


Never come across the price problem, sorry

Please note - if I have suggested a contrib above, it doesnt mean it will work! Most of the contribs are not ones I've used, but may be useful for your particular problem....

Have you tried a refined search? Chances are your problem has already been dealt with elsewhere on the forums.....

if (stumped == true) {


} else {

$random_query = tep_fetch_answer($forum_query)


Link to comment
Share on other sites

price problem is most likely that you have the $ sign in with the amount. remove it.


you have a bug somewhere, if it is saying no model #, did you modify the EP file at all?


also, the next time you post about EP, post in the contribution support thread for EP, as there are a lot more people there who know it, that do not browse the forum. i came across it by chance.


if you need more info in EP, post in there.

Link to comment
Share on other sites

I just uploaded 400 hundred products through MS Access (wasn't that fun!) and all my prices are displaying as 0 in the shopping cart... however in the admin they come up correctly!


I tried adding a product manually and same problem. I only updated three tables: products, products_description and products_to_categories... did I miss something?


I uploaded the prices as normal numbers with four decimal places and they're all sitting happily in the products.products_price field.




Link to comment
Share on other sites

if you guys are wanting support for easy populate, please find the thread in the contribution support area, and post at the end of it. then you will get answers. for your prices via access, is the field set as text?

Link to comment
Share on other sites

I had the exact same problem:


"No products_model field in record. This line was not imported"


But the rest of the products before this ARE uploaded!!!!!!!!


This line simply refers to the last line in your data record (i.e. excel if you are using excel)... that has no info in it!


For the "0" as your price you need to get out of this forum and post it on the general forum, but the answer is this (from Mr_Bear, if you bothered to check previous forum questions):


Did you created a new default currency?

In the edit did you put 1.0000000 as the value and then click on update currencies button ?

and in the catalog/includes/languages/english.php around line 36


// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used w$



Change it to whatever you need


hope this helps

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...