Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Order Editor v1.3 SQL Error


Morb

Recommended Posts

Greets,

 

On 17 May 2004, the Contribution was reuploaded, but I still get an error with the SQL syntax.

 

I'm not familiar with playing around with it....so, don't quite know what to do.

 

This is what I get when I try to add another product:

 

1054 - Unknown column 'ptc.categories_name' in 'field list'

 

SELECT products_name, p.products_id, ptc.categories_name, ptc.categories_id FROM products p LEFT JOIN products_description pd ON pd.products_id=p.products_id LEFT JOIN products_to_categories ptc ON ptc.products_id=p.products_id LEFT JOIN categories_description cd ON cd.categories_id=ptc.categories_id LEFT JOIN categories_description x ON x.categories_name=ptc.categories_name ORDER BY categories_id

 

[TEP STOP]

 

Geof.

www.smoothair.ca

Link to comment
Share on other sites

Did you run the sql file on the database and did it add the column ptc

 

or is ptc meant to be p2c as in product to catalog

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

I'm sorry, I don't know....as I said, SQL illiterate.

 

I am using the file that says .DS_Store, and when I run the query, this is what I get...

 

Error

 

There is a chance that you may have found a bug in the SQL parser. Please examine your query closely, and check that the quotes are correct and not mis-matched. Other possible failure causes may be that you are uploading a file with binary outside of a quoted text area. You can also try your query on the MySQL command line interface. The MySQL server error output below, if there is any, may also help you in diagnosing the problem. If you still have problems or if the parser fails where the command line interface succeeds, please reduce your SQL query input to the single query that causes problems, and submit a bug report with the data chunk in the CUT section below:

----BEGIN CUT----

eNrtmElrwkAUgGdSDzK95NjjO3jUMUvjMie3YAW3GmuvdUNDJVqDYm+e+rv60xrNAwUteCzlfTB8

h1lJYN574/Z6nZ6CqglVC5puW4EBJjh2Li+8ftTBhagOPAWpxkRB+LFYDdfhdC0X/kiu5qv0FkxZ

cMAyDDtr5LNWEYyicgrKKcJsuN76wdwfv/vBDNzdClKi9ek9NxXY0rKlkxMvXg86XhrKdbfdT8PA

jTZ89QNouJCThui2ygos6Ug7sx6bovvUPQxJd6LjPEpLRuf1g81ONMvtuoJpkPHDZaZQcIoZUxy3

4ZXNxGRMZ4wlWWz2xa6SxHaBhuZxi9bYsAmbsnASjhfsNvhxcZ8FbMwW5/NHy+WtaxAEQRAEcTsc

4/s9fQqCIK7cD4AuofexOfZr6MTZHB0N6BJ6H5vjOA2dQCfROhrQJfQ+Nl5aHIsPjjtzrFC4jgZ0

if4jQVzjLpZ+iP/u7/U/QRD/Oc4nal6tcioILtAwEXjDMd+nYH81EdDiB8OHs6TgjyQDP1juTd4=

----END CUT----

----BEGIN RAW----

 

ERROR: C1 C2 LEN: 0 1 5367

STR:

 

CVS: $Id: sqlparser.lib.php,v 1.85 2003/07/29 09:58:59 garvinhicking Exp $

MySQL: 3.23.56

USR OS, AGENT, VER: Win IE 6.0

PMA: 2.5.3-rc1

PHP VER,OS: 4.2.2 Linux

LANG: en-iso-8859-1

SQL: Bud1?udesdsclincludesdsclbool @? @? @? @E?DSDB `? @? @? @----END RAW----

 

SQL-query : 

 

Bud1?udesdsclincludesdsclbool @? @? @? @ E?DSDB `? @? @? @

 

MySQL said:

 

 

#1064 - You have an error in your SQL syntax near 'Bud1' at line 1

 

Geof.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...