Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Path chaos


salewit

Recommended Posts

I've tried and tried to do this on my own, but I surrender. I've been trying to set up my configuration files and having nothing but problems. Here's the situation. I'm creating a store on a multi-hosted account with a shared SSL. The store is in the root (not /catalog).

 

Path to store: www.mydomain.com

SSL path to store: secure22.nocdirect.com/~acctid/multhostfolder

File path to store: /home/mydomain/public_html/multhostfolder

 

Here's the pertinent part of my config:

 

define('HTTP_SERVER', 'http://www.mydomain.com');

define('HTTPS_SERVER', 'https://secure22.nocdirect.com');

define('HTTP_COOKIE_DOMAIN', 'www.mydomain.com');

define('HTTPS_COOKIE_DOMAIN', 'secure24.nocdirect.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/~acctid/multhostfolder/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/~acctid/multhostfolder/');

define('DIR_FS_CATALOG', '/home/mydomain/public_html/multhostfolder/');

 

Everything works up to a point. If I go to the store and try to log in, it switches to the secure mode. When I enter my account info, it gives me a 404 page not found error, but the URL is exactly right. I looked at the error log on the server, and there are no errors. Can't figure this out.

 

Thanks

Link to comment
Share on other sites

Did you put that path by yourself? or with installation process script?

I found somehow using installation script doing fine comparing to add those path manually in configure.php

[.:2s1000s12:.]

"Did I had the dream, or did the dream had me?"

Link to comment
Share on other sites

This is a shared SSL, there is no seperate folder for SSL. I'm using other apps with SSL that do work properly.

 

http:www.mydomain.com/index.php

 

AND

 

https://secure22.nocdirect.com/~acctid/multhost/index.php

 

lead to the same exact place.

 

Derry: I've tried it both ways... several times. I've actually installed OSCommerce about 8 times already, so I've pretty much tried every variation.

 

Here is the live link: www.trainvideodepot.com

 

Try clicking on the login link. You'll see it switch to https successfully. Then enter this test user: "[email protected]" and password "testpassword".

 

After you enter these and click on "signin", you'll get a 404 error. Look at your URL. This URL is exactly correct, and the file it "can't find" IS there.

 

This is the problem I'm having. I've got a ticket open to my host. They say nobody is reporting problems, and that it must be OSCommerce or the configuration.

Link to comment
Share on other sites

paste the top half of your configure.php file EXACTLY as you have it. do not omit anything, other than the database info.

Link to comment
Share on other sites

I just got it! Sheesh... I can't believe the hell I went through on this one. We're talking DAYS ... maybe 20 hours of work. The weird part is that the defines are different than on another OSCommerce I have running on another server. Weird.

 

Here's the gist of it. Apparently it wants the full secure path including the catalog in one define. Then the catalog is just '/'. I have a sneeking suspicion that there is something buggy going on around there as it doesn't seem like it should matter how those two are laid out as long as they lead to the same URL.

 

define('HTTPS_SERVER', 'https://secure22.nocdirect.com/~acctid/multhostfolder');

define('HTTPS_COOKIE_DOMAIN', 'secure22.nocdirect.com');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...