Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Singup Email problems ????


poisontheused

Recommended Posts

Hi, im testing out oScommerce on my local server, everythings going well, except when i try to signup to become a member, after filling in my details i hit the continue button and get a blank page displaying this error:

 

Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing in c:\phpWeb\catalog\includes\classes\email.php on line 500

 

Warning: Cannot modify header information - headers already sent by (output started at c:\phpWeb\catalog\includes\classes\email.php:500) in c:\phpWeb\catalog\includes\functions\general.php on line 29

 

I have the email setup as SMTP, not sendmail.

 

Anyone know how to fix this problem, any help will be greatly appreciated.

 

Thank You

Link to comment
Share on other sites

Hi, im testing out oScommerce on my local server, everythings going well, except when i try to signup to become a member, after filling in my details i hit the continue button and get a blank page displaying this error:

 

Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing in c:\phpWeb\catalog\includes\classes\email.php on line 500

 

Warning: Cannot modify header information - headers already sent by (output started at c:\phpWeb\catalog\includes\classes\email.php:500) in c:\phpWeb\catalog\includes\functions\general.php on line 29

 

I have the email setup as SMTP, not sendmail.

 

Anyone know how to fix this problem, any help will be greatly appreciated.

 

Thank You

Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing in c:\phpWeb\catalog\includes\classes\email.php on line 500

 

Do you config the send email used SMTP ?!

This can be setup in admin control panel.

 

Warning: Cannot modify header information - headers already sent by (output started at c:\phpWeb\catalog\includes\classes\email.php:500) in c:\phpWeb\catalog\includes\functions\general.php on line 29

 

It may be has a little error in the last line in general.php or email.php

 

If you see this file's last line has the space or "enter",

not ?>

 

the error should be occur, please use "Backspace" to del the space

 

 

 

Hope it can help you.

Link to comment
Share on other sites

Thanks for the help, i checked all of those things but couldn't find any errors. And the email transfer method was set to SMTP in the Admin Control Panel....

 

heres what my php.ini file looks like in the mail section

 

[mail function]

; For Win32 only.

SMTP = localhost

 

; For Win32 only.

;sendmail_from = [email protected]

 

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").

;sendmail_path =

 

Could this be the problem, i'm using windows.

Link to comment
Share on other sites

Thanks for the help, i checked all of those things but couldn't find any errors. And the email transfer method was set to SMTP in the Admin Control Panel....

 

heres what my php.ini file looks like in the mail section

 

[mail function]

; For Win32 only.

SMTP = localhost

 

; For Win32 only.

;sendmail_from = [email protected]

 

; For Unix only.? You may supply arguments as well (default: "sendmail -t -i").

;sendmail_path =

 

Could this be the problem, i'm using windows.

I think the php.ini is no need to change.

I setup the SMTP=localhost in php.ini

Link to comment
Share on other sites

Hi,

 

Could this be the problem, i'm using windows.

 

Sure is. :D

 

Peter

I'm using OSC at home one a winxp machine, so windows isn't your problem. I'm at work right now, so I can't check to see what my php.ini has in it for email server. I'll have to check when i get home and get back to you.

9 times out of 10 its a PEBCAK Error (Problem exists between chair and keyboard)

 

Replace that and you're fine...

Link to comment
Share on other sites

Hi,

 

Make it like this ........

 

[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = [email protected]

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =

 

restart your web server, and see if the problem still exists.

 

Peter

Link to comment
Share on other sites

Thanks for the help, everyone, but still no luck. i modified the php.ini file like you said peterr. then i got the following error

 

Warning: mail(): Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in c:\phpWeb\catalog\includes\classes\email.php on line 500

 

Warning: Cannot modify header information - headers already sent by (output started at c:\phpWeb\catalog\includes\classes\email.php:500) in c:\phpWeb\catalog\includes\functions\general.php on line 29

 

I'm really stuck on this one....

Link to comment
Share on other sites

Hi,

 

I'm using OSC at home one a winxp machine, so windows isn't your problem.

 

When Jay asked the question (about Windows), he was referring to the PHP.INI settings, and _that_ is why I answered "Sure is", not inferring a Win problem, but a possible PHP.INI problem. :D

 

Peter

Link to comment
Share on other sites

Whoops, my bad, misread. :P

 

I know when I did set this up at home I had the same issues though, so when I get home, I'll try to find the fix for you.

9 times out of 10 its a PEBCAK Error (Problem exists between chair and keyboard)

 

Replace that and you're fine...

Link to comment
Share on other sites

Ok, had to set mine up with my website's email domain. Otherwise you'll have to set up an smtp server at home...

 

php.ini:

[mail function]
; For Win32 only.
SMTP = mail.XYZ.com; for Win32 only
sendmail_from= [email protected]; for Win32 only

 

HTH

9 times out of 10 its a PEBCAK Error (Problem exists between chair and keyboard)

 

Replace that and you're fine...

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...