Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Register Globals Support


Recommended Posts

I've been running osCommerce 2.2-MS2 for months now with Easypopulate working perfectly. I wanted to fix the security issue with register_globals so that oscommerce would work with register_globals turned off. I did all the necessary changes and the site is now working perfectly fine with them set too off. The problem is that the easypopulate contribution no longer works.


I've gone back through the necessary files to ensure that couple file edits are correct but i can still not get it to work.


When I click Easypopulate now I get a HTTP 500 internal server error.


Any help would be greatly appreciated.




Link to comment
Share on other sites

  • Replies 280
  • Created
  • Last Reply

Top Posters In This Topic

After installing this mod W3C validator can't find m DOCTYPE(although it's added right) and here is what search engines sees in my top body:


Warning /home/....../includes/application_top.php 223

and here is the app.. code:


extract($_SESSION, EXTR_SKIP);


can someone help..this is seo killing for me

Link to comment
Share on other sites

I've done a test install of register_globals 1.5 this evening as my host has just announced that they're going to upgrade to PHP5 in the next month.


After installing, my main site wouldn't display - it just rendered a blank page - and my admin pages displayed the left-hand column but nothing in the main area of the page.


I was very careful in pasting in the updated functions and don't think I made an error. I've had to rever the files back to the original as I don't have a test site to work on and the site is live.


Part of the problem is that I've installed so many contributions over the last few months that I'm not sure what else might be affecting it. Two of the major contributions are SEO URLS and STS.


Any ideas or suggestions would be greatly appreciated.

Edited by andrew71
Link to comment
Share on other sites

  • 3 months later...

Thank you for a wonderful contribution.

Register Globals has been introduced into RC2a.


Register Globals



The following problem occurred by categories.php after it had introduced it.


Error Message


Warning: reset() [function.reset]: Passed variable is not an array or object in /home/myserver.xxx/public_html/admin/includes/classes/object_info.php on line 17


Warning: Variable passed to each() is not an array or object in /home/myserver.xxx/public_html/admin/includes/classes/object_info.php on line 18



MyServer Info


OS: Linux 2.6.9-67.0.20.ELsmp

DB: MySQL 5.0.22

PHP: 5.1.6 (Zend: 2.1.0)


osCommerce Online Merchant v2.2 RC2a



It was not possible to find it though Google and the forum were retrieved.


I want you to help.

Link to comment
Share on other sites

  • 7 months later...

I copied entired files from that patch and row by row, manualy.

I tried to patch a Template Monster Theme, local in my computer.


localhost/install give me a blank page.


i use MAMP for Macintosh.


A full version of Oscommerce RC2a works great on installation in same conditions.


Any ideea?


Thank you

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...