Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Login fails and gives me a 404 error


Paycheck

Recommended Posts

You SSL configuration is incorrect.

 

Matti

Not shure where. My config is set properly as this is the same SSL sever I am using for another cart on the same server Matti.

 

 

 

I have run into this once before, never resolved it. I just logged in again and it worked. Could this partly be casued by cache?

 

The sporadic work and non working after changes are made?

 

I will check my ssl but it has always been

https://source2.ez-web-hosting.com/~surfcamp/

 

JM

Always remember, we need patience, guidance and most of all understanding.

 

My Contributions

Link to comment
Share on other sites

OK I have changed it and it seems to have helped some however it still wants to sign me in after I make changes to the cart. Also I am noticing it is not placing a shipping or billing address in the checkout section? I have it in the set up of the account, It allows me to select one from the address book but this use to be automatic.

 

Any clues?

 

I am having a real problem for some reason with this 2.2 install.

 

JM

Always remember, we need patience, guidance and most of all understanding.

 

My Contributions

Link to comment
Share on other sites

You probably still have a cookie setting problem - post your configure.php (minus db)

 

Matti

Matti this is from my catalog/includes/config.php

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 [URL=http://www.oscommerce.com]http://www.oscommerce.com[/URL]

 Copyright ? 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://surfcamp.com'); // eg, [URL=http://localhost]http://localhost[/URL] - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://source2.ez-web-hosting.com/~surfcamp'); // eg, [URL=https://localhost]https://localhost[/URL] - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'surfcamp.com');
 define('HTTPS_COOKIE_DOMAIN', 'surfcamp.com');
 define('HTTP_COOKIE_PATH', '/shop2/');
 define('HTTPS_COOKIE_PATH', '/shop2/');
 define('DIR_WS_HTTP_CATALOG', '/shop2/');
 define('DIR_WS_HTTPS_CATALOG', '/shop2/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/surfcamp/public_html/shop2/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'xxxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxx');
 define('DB_DATABASE', 'xxxxxxxxx');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

Always remember, we need patience, guidance and most of all understanding.

 

My Contributions

Link to comment
Share on other sites

define('HTTPS_COOKIE_DOMAIN', 'source2.ez-web-hosting.com/~surfcamp');

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

OK made the change and when I add something to the cart it works fine, when I click checkout it shows 0 items in cart and it wants me to sign in again?

 

:huh:

Always remember, we need patience, guidance and most of all understanding.

 

My Contributions

Link to comment
Share on other sites

This type of setup works for me:

 

 define('HTTP_SERVER', 'http://surfcamp.com'); // eg, [URL=http://localhost]http://localhost[/URL] - should not be empty for productive servers
define('HTTPS_SERVER', 'https://source2.ez-web-hosting.com'); // eg, [URL=https://localhost]https://localhost[/URL] - should not be empty for productive servers
define('ENABLE_SSL', true); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', 'surfcamp.com');
define('HTTPS_COOKIE_DOMAIN', 'source2.ez-web-hosting.com');
define('HTTP_COOKIE_PATH', '/shop2/');
define('HTTPS_COOKIE_PATH', '/~surfcamp/shop2/');
define('DIR_WS_HTTP_CATALOG', '/shop2/');
define('DIR_WS_HTTPS_CATALOG', '/~surfcamp/shop2/');

 

Matti

Link to comment
Share on other sites

OK Matti all seems to be working correctly. I do have another question however. I notice that I am not seeing the tax in the confirmation checkout of the order. I have added taxable items to my product but I am not showing items with tax in teh cart. This should not make a difference right. The tax should still calculate based on the product makeup that I gave it.

 

JM

Always remember, we need patience, guidance and most of all understanding.

 

My Contributions

Link to comment
Share on other sites

There is an option in admin->configuration->My Store to select whether to display tax in the catalog/cart - if set to false tax will still show up in checkout confirmation if they are set up correctly :)

 

Matti

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...