Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Getting a // after .com


Demah

Recommended Posts

I'm not sure why its doing it or even how to fix it but I'm getting a // after the .com on my site. And when I right click my images and look at the links they show //images for the location

Link to comment
Share on other sites

You probably have one after

 

define('HTTP_SERVER', 'http://www.yourspecialname.com/');

 

when you should not.

 

Just look at the configure.php file for a couple minutes. You can figure out how it adds the strings together to determine the right paths. Once you understand it you'll know what's wrong.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Here is my config file but I just don't see where it could be the cause of this.

 

 

  Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://kinadirect.com'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://kinadirect.com'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'kinadirect.com');
 define('HTTPS_COOKIE_DOMAIN', 'kinadirect.com');
 define('HTTP_COOKIE_PATH', '//');
 define('HTTPS_COOKIE_PATH', '//');
 define('DIR_WS_HTTP_CATALOG', '//');
 define('DIR_WS_HTTPS_CATALOG', '//');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', '/home/kina24/public_html/');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

Link to comment
Share on other sites

Right here:

 

There's your double slash, right in your face.

 

define('HTTP_COOKIE_PATH', '//');

define('HTTPS_COOKIE_PATH', '//');

define('DIR_WS_HTTP_CATALOG', '//');

define('DIR_WS_HTTPS_CATALOG', '//')

 

You've got osC running in your root folder so these should be:

 

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/')

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...