Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Linking side categories


Guest

Recommended Posts

ok so I have been modifying this file. includes/boxes/information

This is where I need it to be fixed

 

  $info_box_contents = array();
 $info_box_contents[] = array('text' =>                     

'<a href="' . tep_href_link(features.php) . '">' . Features . '</a><br>'. 


'<a href="' . tep_href_link(services.php) . '">' . Services . '</a><br>'. 

'<a href="' . tep_href_link(tech.php) . '">' . Technical . '</a><br>'. 
                                        
'<a href="' . tep_href_link(links.php) . '">' . Links . '</a><br>'. 
       
'<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">' . BOX_INFORMATION_CONTACT . '</a>');



 new infoBox($info_box_contents);

 

If you look at my page www.winksonline.com/catalog you will see the contact us button works, but the features and suff do not. Any help would be great

thanks

chris

Link to comment
Share on other sites

The solution is simple.

 

You have to reference the FILE NAMES, and NOT the php pages when making links in info boxes.

 

This one is correct:

 

<a href="' . tep_href_link(FILENAME_CONTACT_US) . '">

 

 

This is not corect:

 

<a href="' . tep_href_link(links.php) . '">' . Links . '</a>

 

It should be named:

 

<a href="' . tep_href_link(FILENAME_LINKS) . '">' . Links . '</a>

 

....or whatever your Links filename is.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...