Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

What version of OSC?


Guest

Recommended Posts

A couple questions... I need to add CVV support to my clients site. I inherited an osCommerce site that was not customized in a friendly fashion. It has pretty much been hacked up, but thankfully not in the order/checkout process areas.

 

I guess I need to know what version of osCommerce is it as in how can I tell what version they have there? It's probably at least 14-months old.

 

Secondly, if I cannot find a module/hack for this version of OSC that adds CVV support, does anybody know where I can find the query that collects the payment info form fields and inserts them into the DB? Since this install is beyond fixing at this point, I don't mind doing a quick and dirty hack to collect the CVV and then display it on the order page. I have already added the appropriate form field, but I cannot follow the code after that.

 

I'd be willing to pay to get this done if necessary, I'm just sick of it and it's the last thing I need done in order to relaunch this site.

 

Thanks!

 

Utts

Link to comment
Share on other sites

You can find the version they are using in the file. catalog/includes/application_top.php.

it should look like this:

 

// define the project version

define('PROJECT_VERSION', 'osCommerce 2.2-MS2');

 

There is also a contribution for the cc with cvv in the contributions and a large help section on the cc with cvv in the forum

here: http://www.oscommerce.com/forums/index.php?act=ST&f=7&t=40587

 

Please read through the forum a few pages before you click on the link that leads to the contribution so you don't install the wrong one.

Hope this helps you. Lisa

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...