Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

My Site Self-Destructed!


Recommended Posts

I'm still developing the osCommerce part of my site, and I don't get to spend a lot of time on it. The last time I worked on it was two weeks ago. Everything was fine when I left it.


Now, I go to my catalog site and it appears that no images can be found and the css file is not being used!!



I have been unable to figure out what could be wrong. I swear it was working fine when I last worked on it! Does anyone have any idea what could have happened?


Thanks, Susan

Link to comment
Share on other sites

The reason you have problems is that everything on your site is pointed to https and not http.


You use http for most things, except for login and out, set up account, and the checkout process.


It appears that in your config files, where you should have something similar to the following


define('HTTP_COOKIE_DOMAIN', 'www.yourdomain.com/');


You instead have something similar to


define('HTTP_COOKIE_DOMAIN', 'https://yourdomain.com/');


Change this, and you should be ok.


Hope this helps - Vger

Link to comment
Share on other sites

This looks like your problem.



Try removing that line from your header and see if it works. I tried going to https://darachweb.com/catalog/ and received an error.

The reason that it's set as the base href is because it's set that way in the config. Altering the base href in one file will make no difference, it needs to be altered in the config files, and then all base hrefs will point to the correct http designation. Vger

Link to comment
Share on other sites

also look for your host's SSL domain, in the config file you will need to specify this after you figure out why http requests are being served to https.


make sure you keep the https domain (yourhost.com, not darachweb.com) seperate in the config file from the DIR_WS_HTTPS_CATALOG (/~myUserNameOnMyHost/)


Try removing that line from your header and see if it works.


the base href is a normal part of osC configuration. Removing the line will not fix your problem. I think most of the php pages have that line, so you'd have to remove it from a lot anyway.


Besides, it's a php echo call, not a literal "<base href="https://darachweb.com/catalog/">"

This is what it really looks like in index.html

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">


You can see it puts in either the text defined through the config file as HTTPS_SERVER or HTTP_SERVER.

As Vger said, these are probably the same in your config file.

Link to comment
Share on other sites

It looks like there's some clumsy sysadmins out there in the hosting companies. This is the third thread about this in the last several hours. I wonder if all these people are on the same host.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Thanks everyone!

I have contacted my host to see if they can shed any light on what happened. I'll let you know what they say.

Link to comment
Share on other sites

I guarantee that won't help. It has nothing to do with your host. And they will tell you that they don't support third party software.


You have an osC configuration error. If you put your /includes/configure.php file up, we can tell you exactly what's wrong.


The only piece of information you need from your host is the domain name that your files reside on.


i.e. if I want to access my page in secure mode, I have to preface it with this:



That is equivalent to https://www.mywebsite.com if I had my own SSL certificate...

Link to comment
Share on other sites

Reply from my host said (in part): "I don't think anything has changed, but the cpanel updates every night and if it has been awhile since you last looked, it is possible."

Not really any help, but I wondered could cpanel be the culprit?


In the meantime, I have implemented the change that AlanR suggests in this thread (at Apr 17 2004, 03:52 PM):



and that has worked for me, too.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...