Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem With Currency Selection....


Guest

Recommended Posts

Hey I duno if this is in the right place but I have a problem here....

 

If you go to my store, http://ensomartialartssupplies.com/shop/

All the prices come up as 0 - if you select euro they are displayed right and then if you switch back to pounds they come up ok too,but the first thing u see when you enter the store at products with a 0 price... GBP is set as default and in configuation it will change when selected - i reinstalled this just incase it was a bad instal but no difference..... my host says its not his server as others use OC on there - im really stuck here, any ideas?

 

Cheers:)

P

Link to comment
Share on other sites

Did you created a new default currency?

In the edit did you put 1.0000000 as the value and then click on update currencies button ?

and in the catalog/includes/languages/english.php around line 36

 

// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used w$

 

define('LANGUAGE_CURRENCY', 'USD');

Change it to whatever you need

 

HTH

The_Bear

Link to comment
Share on other sites

Hey

 

cheers for your replies. yes as I said i set it as default.

 

 

Bear i didnt do that tho - on english.php... i just did it... it was the only thing i changed it now reads...

 

// if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used when changing language)

define('LANGUAGE_CURRENCY', 'GBP');

 

but now - the site has loads of errors, check it out :s

Link to comment
Share on other sites

hey.. ok i fixed those errors i just reset the file.. but the problem is... whenever i change that bit from USD to GBP it does the same things.. this..

http://ensomartialartssupplies.com/shop/

messes everything up - if i change it back to USD it doesnt stop the errors i have to reset the file, and even with the errors it still hasnt fixed the currency problem.

 

Any one have any further ideas?

cheers:)

 

Sir P

Link to comment
Share on other sites

Hi James.

 

None of the osC constants are being set ??

 

Lines 72 - 79 of /includes/languages/english.php

 

72  // categories box text in includes/boxes/categories.php
 73  define('BOX_HEADING_CATEGORIES', 'Categories');
 74  
 75  // manufacturers box text in includes/boxes/manufacturers.php
 76  define('BOX_HEADING_MANUFACTURERS', 'Manufacturers');
 77  
 78  // whats_new box text in includes/boxes/whats_new.php
 79  define('BOX_HEADING_WHATS_NEW', 'What\'s New?');

 

and for the parse error to be on line 79, it would usually mean line 76 has syntax errors.

 

Peter

Link to comment
Share on other sites

I think ive fixed it :)

 

Seems as tho changing that USD TO GBP inside the file manager currupted the file so i edited offline and uploaded and its all good :)

 

 

Thanks all!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...