Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem with localhost copy of OK web OSC


jujuhost

Recommended Posts

Hello All!

 

As you can tell I'm new here, and I ask only because I've done all that I can and searched the forums without finding an answer that works. :(

 

Basically, I have a functioning OSCommerce MS2.2 on the web, however I wanted to copy that to my local Win2K machine (Apache 1.3x server, PHP 4.3x, MySQL 3.2x). I copied the files over, but I get the following error message when trying to access the index page at: http://localhost/store/index.php

 

Fatal error: Failed opening required 'includes/configure.php' (include_path='..') in c:\program files\apache group\apache\htdocs\store\includes\application_top.php on line 29

 

My includes/configure.php file is as follows:

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://localhost'); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://localhost'); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'http://localhost');
 define('HTTPS_COOKIE_DOMAIN', 'https://localhost');
 define('HTTP_COOKIE_PATH', '/store/');
 define('HTTPS_COOKIE_PATH', '/store/');
 define('DIR_WS_HTTP_CATALOG', '/store/');
 define('DIR_WS_HTTPS_CATALOG', '/store/');
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
 define('DIR_FS_CATALOG', 'c:\program files\apache group\apache\htdocs\store\');
 define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download\');
 define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub\');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be NULL for productive servers
 define('DB_SERVER_USERNAME', '#######');
 define('DB_SERVER_PASSWORD', '########');
 define('DB_DATABASE', '##########');
 define('USE_PCONNECT', 'false'); // use persistent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 

Any help or suggestions much appreciated! Thanks,

 

Juju

Link to comment
Share on other sites

  define('HTTP_SERVER', 'http://localhost'); // eg, http://localhost - should not be empty for productive servers

  define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

  define('ENABLE_SSL', false); // secure webserver for checkout procedure?

  define('HTTP_COOKIE_DOMAIN', 'localhost');

  define('HTTPS_COOKIE_DOMAIN', '');

 

try that

Link to comment
Share on other sites

Cheers. I gave it a go, good idea but I got the same result.

 

I'm wondering if it's something more fundamental with my apache server/PHP setup on Win2K? Reason being, I just tried to install a clean OSC MS2.2 and I got a similar error when trying to run the install script at:

 

http://localhost/catalog/install/index.php

 

Fatal error: Failed opening required 'templates/main_page/header.php' (include_path='..') in c:\program files\apache group\apache\htdocs\catalog\install\templates\main_page.php on line 31

 

Juju

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...