Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problem /w Admin, not a NoOb question Help Please!


ekhestoo

Recommended Posts

I've been trying to figure this problem out for quite a while. I've been getting this error in the Admin panel when trying to add a new product. It keeps saying

 

Error: Catalog images directory does not exist: /home/public_html/images/

 

My images are stored under /home/public_html/images and my store is in the root directory under /home/public_html/images I

 

have changed the permissions to 777 and the driectory does exsist.

The catalog and admin load all past (demo) pictures just fine, but won't allow me to add in any new ones.

 

I'm stuck, don't know what to do. Please help.

 

Thanks,

Edris

Link to comment
Share on other sites

Here is my configure.php from admin directory

 

<?php
/*
 osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
 define('HTTP_SERVER', 'http://localhost');
// eg, http://localhost - should not be empty for productive servers
 define('HTTP_CATALOG_SERVER', 'http://localhost');
 define('HTTPS_CATALOG_SERVER', 'https://localhost');
 define('ENABLE_SSL_CATALOG', 'true'); 
// secure webserver for catalog module
 define('DIR_FS_DOCUMENT_ROOT', '/home/public_html/'); 
// where the pages are located on the server
 define('DIR_WS_ADMIN', '/admin/'); 
// absolute path required
 define('DIR_FS_ADMIN', '/home/public_html/admin/'); 
// absolute pate required
 define('DIR_WS_CATALOG', '//'); 
// absolute path required
 define('DIR_FS_CATALOG', '/home/public_html/'); 
// absolute path required
 define('DIR_WS_IMAGES', 'images/');
 define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
 define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
 define('DIR_WS_INCLUDES', 'includes/');
 define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
 define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
 define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
 define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
 define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
 define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
 define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
 define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
 define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

// define our database connection
 define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers
 define('DB_SERVER_USERNAME', 'myusername');
 define('DB_SERVER_PASSWORD', 'mypassword');
 define('DB_DATABASE', 'mydatabase');
 define('USE_PCONNECT', 'false'); // use persisstent connections?
 define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

Link to comment
Share on other sites

DIR_WS_CATALOG should not be '//' but rather just '/' - I don't know that it's causing this problem of yours, but it's not right in any case.

Chris Dunning

osCommerce, Contributions Moderator Team

 

Please do not send me PM! I do not read or answer these often. Use the email button instead!

 

I do NOT support contributions other than my own. Emails asking for support on other people's contributions will be ignored. Ask in the forum or contact the contribution author directly.

Link to comment
Share on other sites

looks like your problem is here:

 

----------

// absolute pate required

define('DIR_WS_CATALOG', '//');

----------

 

You have to put the full URL to your catalog there if I'm not mistaken...

 

try changing it to:

 

----------

define('DIR_WS_CATALOG', 'http://localhost/catalog');

----------

Contribs added:

AdminLogin-Catalog With Images-Credit Class/Gift Voucher-CoolMenu

EasyPopulate-LoginBox-Paypal Shopping Cart IPN-PDF Catalogs

Product Listing In Columns - Image Strip

--

...the young jedi said to his master "you want me to do WHAT?"

Link to comment
Share on other sites

I've found that when it says "absolute path required" you have to put the full, complete path (ie..http://localhost/catalog rather than just /catalog)

Contribs added:

AdminLogin-Catalog With Images-Credit Class/Gift Voucher-CoolMenu

EasyPopulate-LoginBox-Paypal Shopping Cart IPN-PDF Catalogs

Product Listing In Columns - Image Strip

--

...the young jedi said to his master "you want me to do WHAT?"

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...