Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

ssl problem!


brett_anderson

Recommended Posts

i got a ssl address from my hosting provider. whenever a customer adds a product to the cart and clicks the checkout button, the browe comes up the "the page cannt b displayed. i changed the configure.php to the following code. pls help me fix it. do i need to change any other code anywhere apart from this file to get ssl working? i am newbie to ssl!

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://******');

define('HTTPS_SERVER', 'https://*********);

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://********');

define('HTTPS_COOKIE_DOMAIN', 'https://*********');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/oscommerce/');

define('DIR_WS_HTTPS_CATALOG', '/oscommerce/');

define('DIR_WS_IMAGES', '/oscommerce/images/');

define('DIR_WS_ICONS', '/oscommerce/icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

 

pls note that my hosting provider supports open ssl connection.

Link to comment
Share on other sites

Try this, on the last line (make sure that 'mysql' is inserted)

 

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

And where you have

 

define('HTTP_COOKIE_DOMAIN', 'http://********');

 

Use instead

 

define('HTTP_COOKIE_DOMAIN', 'www.yourdomain.com');

 

Other than that your config file looks okay. Hope this helps - Vger

Link to comment
Share on other sites

thanx rhea for the reply, i did that still the same story. it works jst fine in the http mode but i don't knw why it plays up when its transferred to https. my account for ssl was created a month ago and it shows up the certificate when u transfer to checkout then when u press ok it says page cannot b found with the url

https://*************/***/checkout_shipping.php?osCsid=0a1e1041bcd9a8099e11ce78866017, but in the actual page it says page cannot b found.

 

i might sound a bit silly but is there any other folder where i need to create a folder for ssl? cos i thought ssl is jst a connection and it works directly from the same folders created in normal root directories. i have tried setting persistent connection as both true and false, it doesn't work!

 

 

here is the database connection

 

// define our database connection

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', '*******');

define('DB_SERVER_PASSWORD', '******');

define('DB_DATABASE', '*******');

define('USE_PCONNECT', 'true'); // use persistent connections?

define('STORE_SESSIONS', 'mysql');

?>

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...