Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

A Complete Newbie


Snake

Recommended Posts

Hello there everyone I'm new here and I have no idea how to get started I've installed the .zip download on my pc but...that's all I don't know what host to use and I've looked for help on the main website but it's all open source this and that, that's great ok but I'm lost please help me get started if you can thanks.

Link to comment
Share on other sites

Upload the latest osCommerce becasuse the one they supply through vDeck is old.
This is bad

 

i can't get to the db....
This is a configure.php problem

 

Personally I think that your host should have a working copy of osC available for you to install easily. But saying that, installing it is only a minor step and speed is good in the long run. There are many osC hosts out there (see sponsor on this page). Shop around and don't just take the first recomendation. Do an internet search for "host, osCommerce" and then search the forum section and see if they are mentioned (good or bad) and that will help you make an informed choice. I would start by registering your domain name, not with your host as that puts too many eggs in one basket. Again do an internet search for "domain, registration" and you will find lots.

 

 

[edit - webhosting recommendations/URL's should not be posted - Matti]

Link to comment
Share on other sites

that's what i did.  i'm tryiing to upgrade now and it isn't pretty -- i can't get to the db....

login to http://your_domain_name/vdeck

 

On the left menu, Host Manager>>Databases>>Setup

 

Add a new database, then a user that has access to it.

 

When you install osCommerce, use "localhost" for the database address and then use the name, username, password you just used to set it up.

Link to comment
Share on other sites

Ok thanks so all I have to do is upload all my unzipped osCommerce files onto that site once I make a site? And get started thanks.

You just need to upload everything that is in the "catalog" directory. You will most likely have to chmod a couple of files for it to install, but it will give you a message warning you that you need to do it for the install to complete.

Link to comment
Share on other sites

Hi,

I've created my dbase, ftp'd the catalog directory and tried using the installer but I get ...

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /home/gb***/public_html/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /home/gb***/public_html/catalog/admin/includes/

touch configure.php

chmod 706 configure.php

 

I'm am from the AS400 world, can anyone tell me what the chmod and touch commands do, what manner of language are they and how do I execute them on my hosting account.

Cheers :unsure:

Link to comment
Share on other sites

u need to change the access permissions on those files. In cute ftp you right click the file, then click chmod and you should have the option to change the permissions eg read / write if those done work try chmod 777

 

hope this helps.

Link to comment
Share on other sites

:D Finally installed it and got a free host who accepts MySQL and .php with unlimited bandwidth and space wanna know message me however I'm stuck with a problemo. = Warning: I am able to write to the configuration file: /data/hosted/techmatrix/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

Question HOW THE HELL DO I DO THAT? Thankyou very much ;)

Link to comment
Share on other sites

:D Finally installed it and got a free host who accepts MySQL and .php with unlimited bandwidth and space wanna know message me however I'm stuck with a problemo. = Warning: I am able to write to the configuration file: /data/hosted/techmatrix/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

Question HOW THE HELL DO I DO THAT? Thankyou very much ;)

use an ftp program such as ws_ftp to connect to the server locate the file and right click it, select properties and you should see the checkboxes for permissions set these to chmod 664 (read, write for owner, read only for rest) if you still get the message then chmod 444 read only state for all.

 

SESSION DIRECTORY DOES NOT EXIST

 

change the last line in the following files

 

catalog/includes/configure.php

admin/includes/configure.php

 

from

define('STORE_SESSIONS', '');

to

define('STORE_SESSIONS', 'mysql');

 

perform the sessions changes before performing the chmod to the files

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

Snake

 

For FlashFXP = RTFM

 

CHMOD;

CHMOD is an important command on UNIX servers when dealing with scripts and such for your website. Often when you install a script you have to give it the correct permissions. You do this by selecting one or more files and pressing the CTRL-O key combination, or you can also right-click and select Attributes (CHMOD) from the menu.

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

:huh: Ok I've sorted out my second problem thanks for the help but the error still remains I tried to set the attributes to: 444 because 644 wasn't working (default setting) but when it uploads I try it again and the attributes are still 644 plz help thanks ppl. :)

Link to comment
Share on other sites

Try this for osCommerce install:

 

http://guide.oscdox.com/Installation_Guide...nstructions.htm

 

CHMOD sets the file permissions:

7 means read write and execute

6 means read and write

5 means read and execute

4 means read

3 means write and execute

2 means write

1 means exceute

 

Three groups of people have permission set Owner, Group and Others

 

hence 755 means the owner can do the lot the other two can read and execute

777 gives everyone the permission to whatever they like such as delete the file or replace it with their own (verrrrry dangerous). 706 seems unlikely check the page above.

 

Your FTP client will do this for you but if it's like mine (WSftp) it doesn't use the numbers but the words. You right click the file and adjust the permissions.

 

Hope this helps a little.

:blink: :blink:

Link to comment
Share on other sites

Snake

 

this may be down to your host not allowing permission to chmod below 644 contact them and see if this is the case as some hosts have a policy of not letting users change permissions below 644 if this is the case then ask them to change the permissions for you.

 

If you are unable to get the change to 444 then you have a choice of change servers or remove the error message from the display knowing that your setting is at 644

 

not sure what you mean about when it uploads an ftp should connect to the server and change the permissions to the file on the server no download or upload involved unless you mean when you refresh or when you next connect.

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P

Is your Osc dated try Phoenix  raising oscommerce from the ashes.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...