Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

1046 - No Database Selected


jdessel

Recommended Posts

Hi, I'm brand new to oscommerce and I just installed it on my server. I thought I did everything right but when I went to mydomain.com/catalog/admin after going through the installation process, I received the message below:

 

------------------------------------------------------------

 

1046 - No Database Selected

 

select configuration_key as cfgKey, configuration_value as cfgValue from configuration

 

[TEP STOP]

 

------------------------------------------------------------

 

I went through the Wiki documents and the troubleshooting section doesn't cover this. I'm really a newbie and don't know programming (php etc.)... is there anywhere else on the oscommerce site or anywhere else on the web to find info on troubleshooting? I really appreciate any help anybody can give me.

 

Thanks!

Link to comment
Share on other sites

Yes... at least I think I did.

 

I went into my site's cpanel and created a database and user in the MySQL panel during the installation of oscommerce. Then I entered the info in the installation window and it was accepted so I assumed I did it correctly.

Link to comment
Share on other sites

Try installing again leaving the DB username and passcode blank during the installation. This will let osC set them up for you. The other option is to edit the includes/configure.php file, near the bottom you can manually add your DB information from the DB that you created. The only problem with that is your osC DB tables may not have been created.

 

Peter

Link to comment
Share on other sites

Hi Peter

 

Thanks. I reinstalled and this time I realized that the first time, I shut the window before the very last install screen. It looked like it was starting all over again so I assumed it was finished, and closed the window wondering why the program didn't do a better job of letting me know the installation was completed.

 

It wasn't completed, that's why.

 

Thanks for your help! It all works fine now.

 

Jackie

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...