Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

missing something in ssl?


ASDCO

Recommended Posts

I cant seem to get my os pages into ssl. I can get my homepage to come up HTTPS but not my commerce page. My oscommerce is hyperlinked from my homepage and when I go to oscommerce I lose HTTPS. Heres how I am set up;

HTTP_SERVER my home page.com

HTTPS_SERVER my home page.my web server.com

ENABLE_SSL true

HTTP_COOKIE DOMAIN my home page.com

HTTPS_COOKIE DOMAIN my home page.my web host.com

HTTP_COOKIE PATH catalog/

HTTPS_COOKIE PATH catalog/

(Im on a shared ssl) Is there something here amiss?

Link to comment
Share on other sites

Try:

 

HTTP_COOKIE PATH /catalog/
HTTPS_COOKIE PATH /catalog/

 

I have written the above in your abbreviated style :blink:

 

Matti

Link to comment
Share on other sites

/catalog/ dosn't change anything. It has to be something between my home page and catalog because I can turn HTTPS on and off at my home page so that seems to be working fine up to that point.It seems to have something to do with hyperlinking to the oscommerce pages.

I remember it was working before I added a hyperlink but I had no way of getting from my home page to oscommerce. Is the hyperlink bypassing HTTPS? I have it pointed to>my.com/catalog

Link to comment
Share on other sites

<?php

/*

$Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'asdcompany.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'asdcompany.ixwebhosting.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL',true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'asdcompany.com');

define('HTTPS_COOKIE_DOMAIN', 'asdcompany.ixwebhosting.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', ''); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', '');

define('DB_SERVER_PASSWORD', '');

define('DB_DATABASE', 'osCommerce');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

define('HTTP_SERVER', 'http://asdcompany.com'); // eg, http://localhost - should not be empty for productive servers
define('HTTPS_SERVER', 'https://asdcompany.ixwebhosting.com'); // eg, https://localhost - should not be empty for productive servers

 

Don't do this on the cookie settings :P

 

Matti

Link to comment
Share on other sites

Ummm, that's the way it's supposed to work. :huh: You don't want your whole site on https. It would be painfully slow.

Link to comment
Share on other sites

It looks as though you did not make the necessary changes in catalog/includes/configure.php - also, if you have a configure.php in your 'local' directory, then this will override the other.

 

BTW, you should not go directly to https://yoursite.com/catalog - SSL mode is only for checkout and account files.

 

Matti

Link to comment
Share on other sites

SUCCESS!! thank you for all your help, the problem was in the local config.php.

DEFINE SSL was set to 0, I changed it to 1 and now everything appears to be fine. Again,thank you all very much.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...