Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

register_globals


tjrac

Recommended Posts

Hi Folks,

 

I've just downloaded the software and uploaded to a host server. When I run the install script I get this ...

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

My shared hosting service provider will not enable this due to security issues. I read somewhere that register_globals was being removed. If that has not happened can anyone suggest a work around? I've managed to resolve the sessions and permissions problems on my local machine, however I'm new at this remote LAMP server account stuff.

 

Thanks!

 

Tom

Link to comment
Share on other sites

Did you find a solution for this man? 'Sides the ever so helpful "find a new host" solution. :blink:

That is a solution smart guy. OSC won't work in this situation. Period. Why are people so scared to move to a new host? They're a dime a dozen. There's plenty of good hosts out there that OSC will work on. Why sit around with your thumb up your butt crying because it won't work on the host you're with? :unsure:

Link to comment
Share on other sites

  • 1 month later...

How about, because I just payed $ 200.- for a new year of hostingsubscription and the hosting company suddenly finds it's time to set the register_globals to OFF for securityreasons.

 

Sure I can pay another 200 bucks for another provider, but that's just not the solution, I'd say. (no offence to your remark, but this is just how it is <_< )

 

Cheers, Frank

Link to comment
Share on other sites

I answered this in one of my other posts today.

 

First Register_globals is off in php.ini error

 

How to fix the quick way!

 

Add a line in your attaccess in both your public "httpdocs" and secure "httpsdocs" directories.

 

php_value register_globals 1

 

By using the above command you will not have to beg your webhost to turn on globals in the php.ini file. You will command them on for your site.

 

Anyway I hope this helps!

 

Newbie helping newbies.....

 

Smarts Auctions

Link to comment
Share on other sites

php_value register_globals 1 already exists in my .htaccess file which is inside my "apache/catalog" folder. You mentioned both the public and secure directories. Is there another place that the change needs to be made other than the aforementioned folder?

Link to comment
Share on other sites

you should have both a http directory and a https directory both have an .htaccess file that you will need to add this line to.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...