Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Trying to Install


New2OSC

Recommended Posts

Hi Everyone,

I have been trying to find a solution to my install problem and have read many posts with no workable solution yet. Here is my problem.

 

I am trying to install OsCommerce for a while now and cannot get past the "import database" screen.

I have read both the wiki docs and the MySQL doc to see if they give my any hints and nothing works. I have worked through the MySQL tutorial and confirmed that the program and my newly created database works. I have imported the sample database manually and can see all the tables and query from it using both commands in shell and PHPMyAdmin. I have been successful in manually confirming the database and I believe I have loaded PHP and MySQL correctly. I am using PHP 4 and above and MySQL 4 and above.

 

With everything I have tried, I still have not been able to get past both the Import database screen nor the New Installation screen. I have gone through every line in the help/install docs and still cannot get it to install. Does anyone have any suggestions?

 

Please and thank you.

Link to comment
Share on other sites

If you've got the database imported just give up on the installer.

 

Open up the configure.php files and edit them, it's simple.

 

Do catalog/includes/configure.php first.

 

Just have a look and see if you know everything you need to fill in the blanks.

 

If you have trouble post the config files here, in this thread

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

thanks Jared and Alan for your replies.

 

Alan's suggestion worked!!!

Afer I edited the configure.php file with the proper information, the site came up.

 

Now comes the work of trying to figure out how to get into the administration part .

 

I hope this post will help out the others that I have read here with this same problem.

 

Again, thanks greatly for your assistance!! You guys are awesome.

 

p.s. Jared, I was not getting any error messages at all. it would just print out the top 10% of the screen and hang there. I had no indication of what the problem was. I think that was the hardest part, trying to troubleshoot with no information to start with.

Link to comment
Share on other sites

If you've got the catalog/incudes/configure.php working the catalog/admin/includes/configure.php file should be easy.

 

It's almost the same.

Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux

Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...