Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Option Type Feature-Not displaying txt Option Name


teamplayer2

Recommended Posts

I have recently installed Option Type Feature v1.6 (for osc 2.2 MS2) but having problem with Shopping cart. The shopping cart is not displaying the Option Name or the Text I entered in the textfield. It just show as '-' and nothing after that.

 

I have followed all the steps in Readme.html and made sure I have everything setup correctly. I also made sure the changes I made were as per instructions in my shopping_cart.php. I search all the forums where people are having similar issues but no clear solutions. I have not tired with checkbox or radiobuttons yet as I don't need them.

 

 

If anyone know how to fix this, please help me.

 

Here how I setup my tables as per instructions in readme.html.

 

PRODUCT_OPTIONS table

------------------------------

products_options_id: 18

language_id: 1

product_option_name: Neck

product_options_type 1

 

PRODUCT_OPTIONS_VALUES table

----------------------------------------

products_option_values_id: 0

language_id: 1

product_options_values_name: TEXT

 

PRODUCT_OPTIONS_VALUES_TO_PRODUCT_OPTIONS table

---------------------------------------------------------------------

product_options_values_to_product_options_id: 39

product_options_id: 18

products_options_values_id: 0

 

PRODUCT_ATTRIBUTES table

---------------------------------

products_attributes_id: 61

products_id: 40

options_id: 18

options_values_id: 0

options_values_price: 0.0000

price_prefix: +

 

 

 

 

Configure.php

----------------

 

// CLR 020605 defines needed for Product Option Type feature.

define('PRODUCTS_OPTIONS_TYPE_SELECT', 0);

define('PRODUCTS_OPTIONS_TYPE_TEXT', 1);

define('PRODUCTS_OPTIONS_TYPE_RADIO', 2);

define('PRODUCTS_OPTIONS_TYPE_CHECKBOX', 3);

define('TEXT_PREFIX', 'txt_');

define('PRODUCTS_OPTIONS_VALUE_TEXT_ID', 0); //Must match id for user defined "TEXT" value in db table TABLE_PRODUCTS_OPTIONS_VALUES

 

 

Anyone see any problem with my setup?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...