Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Setting up on ssl unusual problem


zabaman

Recommended Posts

Hi, I have searched the forum but I have not found a similar problem The problem being:

I am having difficulty getting the ssl facility to work properly with the domain www.mydomain.com, the secure server is on a shared server. I am now running out of time and in desparation. Please can someone shed light..

 

I have changed the parameters in the the /includes/configure.php file and uploaded this to the secure server (as well as the non-secure server). When you log in using your registered details it pulls up the correct page on the secure server (https://secure.server.co.uk/www.mydomain.com/login.php when you submit the form it goes to the url https://secure.server.co.uk/index.php but that file does not exist because the correct place it should be looking is https://secure.server.co.uk/www.mydomain.com/index.php. The directory structure and the files are the same on both the secure server and the regular server. I can not understand why it pushes it off okay to the secure server but then the url changes. Heres a copy of the config file with the curent details. (note the names of the servers have been changed for security reasons).

 

define('HTTP_SERVER', 'http://www.mydomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://secure.server.co.uk'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.mydomain.com');

define('HTTPS_COOKIE_DOMAIN', 'www.mydomain.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', 'www.mydomain.com');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/www.mydomain.com/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/1234/myusername/www.mydomain.com/public_html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

Link to comment
Share on other sites

Hi everyone, you can ignore this post as I have found out the solution. I needed to add the full path to the secure server, and remove the directory path from the https directory setting. It works as it should do now.

 

sorry to bother you!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...