Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Configuration - Email Send


Recommended Posts



First of all, this only applies to the 2.2 Milestone 2 version. Second, this post is written for the masses, so all your high end users bare wih me.


As many of you, we often run into weird email problems were stuff does not get sent, or (i.e.) the "send Mail" form works, but none of the "forgotten password" or other email notifications do not. Many times this will happens after contributions updates or, even more often, sloppy work, residual files not properly remove, sql inserts with conflicts, etc.


I spent most of today using this forum looking for answers to my problem, and I found many posts dealing with this kind of error, but none really applied to me. I eventually worked out my bug and I figure I may as well post it here in case someone else runs into this:


Problem: As stated, email confirmation, password recovery, etc did not work. None of the clients got any emails "except" when using the "Send Email" feature in the Administration panel>Tools>Send Email form. Anything else, nothing.

A few variables about my case:


A) I did tried out quite a few contributions (STS, BTS, Admin Product Sorting, and a few other)]

B) The email functions all worked fine, then stop working. (Note: A few weeks lapse between the finishing of the project and when the email problem begun, so I could not pin point the exact moment the email stop working.)

C) All the features seemed to work, except the email. For example, when using the password recovery form (password_forgotten.php), the form would process the request as always, the new password was generated (I tested it) and the form properly confirmed the email was sent. The single thing not working was the email never arrived.


If this situation is similar to what is happening to you, check this:


A) Go to the Administration, select "Configuration"


B) First, click on "Email Options" under "Configuration".. IF THE PAGE COMES UP BLANK (with the proper header, footer and table, just nothing on it) YOU HAVE AN SQL PROBLEM. However, chances are oher "Configuration" features may not work. In my case, from the "Cache" down to "Sessions" all showed up blank. I suggest you go up and down and click in all the "Configuration" links to make sure no other ones show up blank.


Basically, if this happens to you is because you accidentally erased rows in your MySQL "configuration" table that provide the information for the blank pages. One of those can be the Email Options, and if that happens, no emails get sent. That was my problem.


When you run your mouse each link under "Configurations" you see the url ends in a "gID=" (i.e. gID=8, gID=9, gID=10), which stands for Configuration Group ID. This way you can quickly identified the missing group ID for each feature. I then went to phpMyAdmin, looked up the "configuration" table (browse). Each row has a "configuration_group_id" field. I went down the list until I confirmed the missing pages were also missing rows in the mySQL database. (For example, the Email Options configuration_group_id/gID is "12". None existed.


To solve it, I just reopened the SQL file that came with OSC 2.2 in a text editor, located the INSERT commands for the missing rows using the configuration_group_id numbers (just first find the block were the "configurations" rows begin, then located the proper ones using the gID), paste it into the phpMyAdmin, excuted the SQL....Rows got inserted, all with the proper configuration_group_ID. all the blank pages came back up, and the email begun to work again.


I am sure there can be many other variations of the same problem, so with that on mind< I will always check SQL configuration_group_ID for missing ones, or changed ones, or similar stuff.



Ok. This feels good. Laters.

Link to comment
Share on other sites

  • 3 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...