Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

LinkPoint error messages on checkout


Recommended Posts

We are trying to get the Linkpoint module working. We got the .pem file from them and are using the LinkpointMS1andMS2v2.zip file on the site. We are getting the following error message when we attempt to use it (directories edited):


Warning: before_process(includes/linkpoint/lpphp.php): failed to open stream: No such file or directory in /home/mystore/public_html/store/includes/modules/payment/linkpointms1.php on line 192




Warning: before_process(): Failed opening 'includes/linkpoint/lpphp.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mystore/public_html/store/includes/modules/payment/linkpointms1.php on line 192




Fatal error: Cannot instantiate non-existent class: lpphp in /home/mystore/public_html/store/includes/modules/payment/linkpointms1.php on line 194




We have checked to make sure that the directories are there. We have edited the paths to no avail. Any assistance appreciated.



Link to comment
Share on other sites

I got that one too. Called Linkpoint. Changed my path to linkpoint.php and the .pem file to an absolute path, C;\www\mydirectory\catalog\linkpoint.

Solved my problem.

If you choose not to decide you still have made a choice, I will choose a purpose clear, I will choose Free Will. --Neal Peart - Rush

Link to comment
Share on other sites



Could anyone explain this more clearly, I am having the same problem as mentioned above, but I don't quite understand where these paths are found:




I got that one too. Called Linkpoint. Changed my path to linkpoint.php and the .pem file to an absolute path, C;\www\mydirectory\catalog\linkpoint.

Solved my problem.




I do not see a path in my .pem file nor do I see a linkpoint.php file. I am using the LinkpointMS1andMS2 addon.





Link to comment
Share on other sites

  • 1 month later...

Line 194 is the first line of code after the path statement to find linkpointms1.php.


There are two linkpointms1.php files in the contrib.


1 [file size - 1686] must be put into /catalog/includes/languages/english/modules/payment/ on your server. Exchange "catalog" with whatever directory name you have chosen to install it to such as "shop/" or "store/" .


If you are on a shared server you most likely do not have root level SSH to see the actual path. Suffice it to say when you FTP into your hosting company, you are at root. Root normally will have, depending on your hosting companies operating system (windows, linux, BSD) either a "public_html" or a "httpdocs" folder in which you have installed OS Commerce. This is your WEB or "WS ROOT" and would be where you kept your index.html file for your website.


If you have installed OSC into that directory and in a subdirectory of it called "catalog" then your store would be found on the web at http://www.domainname.com/catalog/index.php


So knowing this path using ftp, we can upload the files to the correct locations.


We will assume that you have extracted the contribution in winzip to c:\ and made sure the "use folder names" choice was checked so that the linkpoint module extracts on your PC's hard drive to c:\linkpointMS1andMS2\catalog\*.*


The files, if you used the "use folder names" option in winzip are already in the correct locations.


Open your FTP client, select all of the files in c:\linpointMS1andms2\catalog but not the catalog directory itself and upload them into your store names directory i.e. public_html\catalog\ or httpdocs\catalog\.






I can tell a few of you are getting errors and its not working because you have uplaoded them to the wrong locations.


for instance the second and larger of the two linkpointms1.php file goes in /storename/includes/modules/payment/ so if your directory on your server is /home/username/httpd/vhosts/domainname.com/catalog this file needs to be in home/username/httpd/vhosts/domainname.com/catalog/includes/modules/payment/



If you cannot get this to work and can provide me with root level acces via SSH or can get me ftp access i will try to fix it for you.




Clifton C Murphy Jr.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...