Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Dont mean to start a new topic


Recommended Posts

Ok, basically i did a fresh install thru CPanel, then i added STS 1.8 Everything came out perfect. Now the page looked perfect and all i had to do is add my products (let me tell you iall background colors and logos and all were showing perfect..cant strain it enough). but i delayed

so later i come back and and goto my config page for oscommerce and that worked perfect. then i tried to view something i edited in my store and all the writing is there but no pictures and no color.


check it out eden Micro PC Web

i have double checked all the folders have what they should...i have no freaking clue, hopefully its them and not me.

Edited by infinid
Link to comment
Share on other sites

this is my configure.php from my /public_html/store/includes folder




$Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $


osCommerce, Open Source E-Commerce Solutions



Copyright ? 2003 osCommerce


Released under the GNU General Public License



// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://edenmicro.net');

define('HTTPS_SERVER', 'https://edenmicro.net');

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://edenmicro.net');

define('HTTPS_COOKIE_DOMAIN', 'https://edenmicro.net');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/store/');

define('DIR_WS_HTTPS_CATALOG', '/store/');

define('DIR_WS_IMAGES', '/store/images/');

define('DIR_WS_ICONS', '/store/icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');


define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');



// define our database connection

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', 'edenmic_osc3');

define('DB_SERVER_PASSWORD', '**********');

define('DB_DATABASE', 'edenmic_osc3');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql');

// STS: ADD: Define Simple Template System files

define('STS_START_CAPTURE', DIR_WS_INCLUDES . 'sts_start_capture.php');

define('STS_STOP_CAPTURE', DIR_WS_INCLUDES . 'sts_stop_capture.php');

define('STS_RESTART_CAPTURE', DIR_WS_INCLUDES . 'sts_restart_capture.php');

define('STS_TEMPLATE_DIR', DIR_WS_INCLUDES . 'sts_templates/');

define('STS_DEFAULT_TEMPLATE', DIR_WS_INCLUDES . 'sts_template.html');

define('STS_DISPLAY_OUTPUT', DIR_WS_INCLUDES . 'sts_display_output.php');

define('STS_USER_CODE', DIR_WS_INCLUDES . 'sts_user_code.php');




Edited by infinid
Link to comment
Share on other sites

Your baseref is getting set incorrectly. I.e. it is showing as https://edenmicro.net/store/ instead of http://edenmicro.net/store/


That is why your images and stylesheet are not showing up. Btw, your COOKIE_DOMAIN settings should not have the http:// in them, just the domain names.




Always back up before making changes.

Link to comment
Share on other sites

Ok, so I'm not sure what the baseref problem is, but change these:


define('HTTP_COOKIE_DOMAIN', 'http://edenmicro.net');
define('HTTPS_COOKIE_DOMAIN', 'https://edenmicro.net');




define('HTTP_COOKIE_DOMAIN', 'edenmicro.net');
define('HTTPS_COOKIE_DOMAIN', 'edenmicro.net');


optionally, you can have them be


define('HTTP_COOKIE_DOMAIN', 'www.edenmicro.net');

define('HTTPS_COOKIE_DOMAIN', 'www.edenmicro.net');


if you think you're never going to use any subdomains (because specifying the www. means that it will not place cookies from the subdomains).


When I visit your site, it is correctly specifying http://, so I don't think you have the https problem anymore.. although I can't seem to find your store at all..lol

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...