Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Fatal error


Recommended Posts

O.k., was working late on things last night, everything was fine when I turned off my browser and went to bed.


Trying to view the shop today, and I get this:


Fatal error: Failed opening required 'includes/languages/.php' (include_path='.:/usr/share/pear') in /home/reefnut/public_html/reefshop/includes/application_top.php on line 285


I fixed a problem on my own last night, but this one I do not even understand where to start experimenting (following backing everything up ;) )


Any help? Link to see exactly is http://www.reefnut.com/reefshop/

Link to comment
Share on other sites

No, I made backups of the 'includes/configure.php' and 'admin/includes/configure.php' because that is what I was working on. On the site itself I just removed some countries and changed the main display text according to one of the articles here.


IOW, no I didn't, didn't think the minor changes were that big of a change...although I'm sure they are the famous last words of a noob. <_<


Can I run a fix with phpmyadmin or something?

Link to comment
Share on other sites

Thanks for the tips, I looked through all the files in my catalog and php.ini is not there. So....this means it evidently is part of the database somehow? Can you lead a bit further as to how to get to it? I have phpmyadmin...I cannot log onto any page of my catalog or the admin tool.



Link to comment
Share on other sites

Hey Hoops,


Have you tried changing 'includes/application_top.php on line 285' :


require(DIR_WS_LANGUAGES . $language . '.php');




require(DIR_WS_LANGUAGES . 'english' . '.php');




Assuming your /includes/languages/english.php is still intact



Link to comment
Share on other sites

Did you edit english.php with the file manager?????

This looks like you have extra line at the bottom of english.php common with the file manager. Suggestion, pull english.php down and edit in a php editor and reload, overwriting the original file.

(Quoting Bloodshoteyes)

Link to comment
Share on other sites

To my knowledge, I didn't edit english.php at all. The only thing I edited were the configure.php files in the catalog and admin section with my website and database information. When I started editing the catalog, I simply replaced the osCommerce picture with my own and editing some of the wording on the front according to the directions on the generic catalog index page.


Everything was fine after all my editing, I even showed the progress of the shop to my girlfriend. I cruised around the catalog a bit thinking of ideas, and then turned the computer off and went to bed. When I went to check the catalog during free time at work...the fatal error was up. I figure something happened with a table between that time period. I have had a similar error before on a PHPBB forum I run, but with that the table with the error showed up on phpmyadmin. I find no such tables as in the different wording of this particular error. I am trying as well to set up a mySQL manager program for a potentially more comprehensive view of the tables, but that has not gone very well either.


At some point, if I reach a dead end, can I simply reinstall over this...or ask my host to purge the recent osCommerce database submission and start over?

Link to comment
Share on other sites

It is due to register_globals Off in your php.ini file.

set it to register_globals On.


FWIW, by creating a phpinfo.php file and uploading it I have been able to view my settings. register_globals is already set to "On".

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...