Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Images Not Showing


Recommended Posts

I have a bit of a mind-boggler (for me at least it has been!). I am new to php and pretty much everything else non-Microsoft and I am trying to set up an osCommerce store, and the images for the products are not cooperating. I was able to customize the store to some degree as far as appearance and such, and have my images folder chmod to 777 and I get no errors...

But what happens is when I choose the product image when making a new product, the image is in fact uploaded (to /catalog/images/) but when browsing the catalog (or even when the product is added and you are seeing it in the admin area) the image is always the "Red X" and will not display.

I had originally changed the WS_CATALOG_IMAGES to be images/products/ but when I found it not working, I changed everything back, and still no luck. I did find that when I uploaded images, they were being set to chmod 777, and when I changed an individual picture to chmod 644 instead (like the images that come with the install), instead of a red x I got an image about 300w x 300h which would be correct, but only the top like 5 pixels or so showed, the rest was not there.

To really confuse me... Even if I browse directly to the file name in a separate browser window, the file still shows up as a Red X!!! I have previously uploaded images that show just fine in other areas of the store (such as the shipping page has a UPS estimated time in transit map gif). That image was uploaded via FrontPage.

I have just checked though, and now no matter how I upload an image to the site, it is not showing up if I place it in /catalog/images/ directory. I have tried the store's new product upload, frontpage, and the file manager in my control panel, all to no avail. If anybody has any suggestions please :)

I am at a complete loss on this one.

Thanks again,


Link to comment
Share on other sites

Ok an update to this... I should really have thought of this before...

I tried to upload via ftp transfer and the images were still not viewable.. So I attempted to open one of the images in question via Photoshop... Wasn't working... So I went back to the originals, and they were fine... What apparently happened is my initial image download from the webserver (I had manually uploaded all the images, not realizing oscommerce would upload them for me when I created the product) was a transfer of images to garbage files :(

Nothing was wrong beyond th is. I attempted an upload of my original files, and they display perfectly, and then I created a new product, and they are looking good now.

At least I was able to catch this before anybody else had to waste a bunch of time raking their brain too :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...