Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

SSL HTTPS problem


Recommended Posts

After installation of OSC 2.2 M2 on my shared server I have problem when accessing page over secure socket layer.


Please if anyone have time to check this at :


http://www.shopsurfing.com/index.php - works

https://www.shopsurfing.com/index.php - problem


I have the catalog config.php as shown :


define('HTTP_SERVER', 'http://www.shopsurfing.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://www.shopsurfing.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.shopsurfing.com');

define('HTTPS_COOKIE_DOMAIN', 'www.shopsurfing.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/');

define('DIR_WS_HTTPS_CATALOG', '/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');


define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/home/httpd/vhosts/shopsurfing.com/httpdocs/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');




what is wrong here ?


Thank you



Link to comment
Share on other sites

No this is server with shared certificate, and originally the physical address of ssl were in separate directory (https at httpsdocs and http at httpdocs). I asked to redirect all ssl calls to same httpdocs directory and after that I have this problem.

Link to comment
Share on other sites

You are on a Plesk server. Your shared ssl probably won't have a ~ in the username. Has your ISP enabled a shared ssl for you in Plesk or were you just using the one that has access to the control panel. With plesk if you are using your own domain for the ssl, the "shared" ssl is just a self-signed one for your site, gives permission warnings. You really should buy another IP if it's not too much & have a real ssl cert installed. No one likes to get warning messages when they are navigating to your secure pages. I may be way off. I have a Plesk server, that's how it worked for me. (Other than problems with email using Plesk).



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...