Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Article Manager v1.0


Recommended Posts

Looks like you missed the language file defines that belong in catalog/includes/languages/english.php.


define('BOX_HEADING_ARTICLES', 'Articles');


...and so on.


Look in the Readme.txt file that is included with the contrib, for the following line...

In includes/languages/english/english.php add the following

Below this line, you will fnd all of the language file defines.



Link to comment
Share on other sites

I'm using 1.2 and it seems to be working fine except.... some articles simply won't "insert". I click on it and it just hangs there. Now my suspicion is that it's not a problem with the mod but rather with using (in these 2 particular cases) named anchors and javascript within an htmlarea. For example: 1 of the "articles" I am trying to add is a simple currency converter for my overseas customers. It is a 3rd party javascript and goes in fine in html source view, previews fine but then, when I click on "insert" just sits there. Anyone have any tips for working around this?


(And here is the code if anyone wants to try to duplicate the problem)

<!START theFinancials.com Content>

<!copyright theFinancials.com - All Rights Reserved>

<p style='visibility : hidden; margin-top: 0; margin-bottom: 0'>

<a href='http://www.thefinancials.com/'></a></p>

<script LANGUAGE='JavaScript'



<script LANGUAGE='JavaScript'



<script LANGUAGE='JavaScript'>

document.writeln(theFinancialsConverter('','#000080','#FFFFFF','#C0C0C0','#000000','Arial, Helvetica'));


<!END theFinancials.com Content>

Link to comment
Share on other sites

  • 2 weeks later...

Hi there,


This is what I was searchig for, but I have a problem!!!


I have installed "Article - Content Management"




to show special articles without prices, and I want to install your "Article Manager v1.0" to write and show articles related to my products, but "Article Manager v1.0" use some tables and .php files with the same name than "Article - Content Management", is there any possible solution???



Link to comment
Share on other sites

Hi Rob,


Are you planning to ad to your contribution - Article Manager - this features?


- attach to every article some images. Like in the NewsDesk

- feature StickyArticle - like in the NewsDesk. To highligth some article as a main article.




Link to comment
Share on other sites



I installed this contribution and I think I installed it correctly. I do have one problem with the admin section of it though. It may be my fault, maybe not, But I would like to have somone look it over.


When I click

in the admin panel it takes me to the screen and half loads. I recive this error:
Fatal error: Call to undefined function: tep_get_topic_tree() in /home/getled/public_html/admin/articles.php on line 963


Intresting eh?


Well when I look in the code to figure it out, see if it was something I did wrong when installing, I see line 961-965 says

   echo tep_draw_form('goto', FILENAME_ARTICLES, '', 'get');
   echo HEADING_TITLE_GOTO . ' ' . tep_draw_pull_down_menu('tPath', tep_get_topic_tree(), $current_topic_id, 'onChange="this.form.submit();"');
   echo '</form>';


Seems like a function brought on by the artical.php code itself, nothing I edited...


Any thoughts? Im lost..

Link to comment
Share on other sites

Sorry for posting AGAIN but I have one last problem.


when I go to articles.php and it loads it say,


All Articles


Current Articles


There are currently no articles listed.


The thing is, I have a topic and two articles set up and can see them in the admin panel. So what gives?

I have STS template installed, Additional images and Header Tags Controller v2.2.


How do I go about getting them to show?

Link to comment
Share on other sites



I recently installed your Article Manager module and I am finding that once I click on an article, the 'Articles' link disappears from the top navigation bar (application_top.php) in my store. Breadcrumb problem, maybe?? Is this a known issue or have I done something wrong? With out this link the user cannot get back to the main Articles page unless they scroll down to the box.


Any thoughts?



Link to comment
Share on other sites

I found that Article Manager was not working with Simple Template System 1.9 and higher with the Header Tags Controller installed. To get the HTC and STS to work I stated in a previous post that all that was needed was to disable the HTC code in /catalog/includes/application_top.php, since STS has HTC support built already. Here's what I actually did to make everything play well together:




AM specifies to comment out the following line if HTC installed:

  require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');

Line is left intact.


HTC adds the following code:

  // BOF: WebMakers.com Added: Header Tags Controller v1.0
   require(DIR_WS_FUNCTIONS . 'header_tags.php');
 // Clean out HTML comments from ALT tags etc.
   require(DIR_WS_FUNCTIONS . 'clean_html_comments.php');
 // Also used by: WebMakers.com Added: FREE-CALL FOR PRICE
 // EOF: WebMakers.com Added: Header Tags Controller v1.0

Comment out or delete this section. STS has support for HTC in sts_display_output.php.



Added the following line to the end of the file, before the closing ?> tag:

  // flag to determine whether to use custom tags or article header tags with STS
 $use_ah_tags = 'true';



Comment out or delete the HTC <?php ?> code blocks immediately above and below the

  <title><?php echo TITLE ?></title>



Changed the code between <!-- header //--> and <!-- header_eof //--> to the following:

<!-- header //-->
<?php require(DIR_WS_INCLUDES . 'header.php'); 

// Moved header tag call to here to facilitate STS blocks
if ( file_exists(DIR_WS_INCLUDES . 'article_header_tags.php') ) {
 require(DIR_WS_INCLUDES . 'article_header_tags.php');
<!-- header_eof //-->



Lines 149-167 (stock file) are HTC support code.

Changed the code to the following:

// STS: ADD: Support for WebMakers.com's Header Tag Controller contribution
 // BOF: WebMakers.com Changed: Header Tag Controller v1.0
 // Replaced by header_tags.php
 // Modified to work with Article Manager (which uses custom headers)
 if ($use_ah_tags == 'true') {
   // require(DIR_WS_INCLUDES . 'article_header_tags.php');
   // don't process HTC - use headertags from article_header_tags
 } else {
   // Capture the output
   if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {
     require_once(DIR_WS_FUNCTIONS . 'clean_html_comments.php');
     require_once(DIR_WS_FUNCTIONS . 'header_tags.php');
     require(DIR_WS_INCLUDES . 'header_tags.php');
   } else {
     echo "<title>" . TITLE . "</title>";
   $sts_block_name = 'headertags';

 // EOF: WebMakers.com Changed: Header Tag Controller v1.0
// STS: EOADD: Support for WebMakers.com's Header Tag Controller contribution




Link to comment
Share on other sites

Great contribution - this is exactly what I needed in OSC. But I'm having a real newb problem here. Warning: much more likely a redhat/mozilla issue than with this contrib:


I'm running OSC2.2ms2 on apache/redhat and accessing the admin page via Mozilla 1.5 from a redhat 9 workstation. Attempting to clipboard-paste html articles into the admin interface I find it just won't take more than 50 lines at once. I have a lot of long articles to post and therefore this is making a lot of extra work. I've tried updating the database in phpMyAdmin but there's still no easy way.

Link to comment
Share on other sites

Hi there!


Maybe someone can help me please.


I installed the article manager v1.2.

I think I did everything right (but I guess not).


My first problem was:

After installing I couldn't see the "article manager" in my admin panel.

So I created a new user group in "configuration_group" with "configuration_group_id" = 456

Now I can edit the options.


My second problem is:

In the "Articles" Box always shos "0"

New Articles (0)

All Articles (0)


And sorry about that stupid question now:

Where can I "associate articles with products" for examples and all other features.


Thnx a lot!


Greets, Martin

Link to comment
Share on other sites

you can get this to work on ms1


i tried to install it on ms1


Warning: Missing argument 3 for splitpageresults() in c:\program files\easyphp\www\rc\catalog\includes\classes\split_page_results.php on line 24

Warning: Missing argument 4 for splitpageresults() in c:\program files\easyphp\www\rc\catalog\includes\classes\split_page_results.php on line 24


do u guys knows some contribution written for ms1 that would be similar to taht one ?


Link to comment
Share on other sites

Please post any bugs and suggestions about Article Manager v1.0 in this topic. I will do my best to provide support.


Thanks ;-)


Rob Anderson

hi Rob


i have problem in reviews status.

A must have status new reviews in articles pemanently approved YES.

Defoult is NO.

How do i can change this ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...