Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Payment Problem


eHo

Recommended Posts

Hey Anyone,

 

Weird problem for me. I have Apache running on my machine with OSC 2.2 and it works just fine. I have uploaded it to my public server (same copy) and I get a neat little problem.

 

For some reason when I check out, I get no options for payment. It works fine on my local server.

 

I wiped out my database, (installing a fresh copy as we speak) and tweaked everything I could think of.

 

If anyone has run into this before please let me know. I would really, really, really like to get this resolved in the super near future.

 

Thanks again in advance for any help you may provide.

Link to comment
Share on other sites

I would just like to say that I am a moron and I figured it out on my own.

 

Just for peace of mind YES I had payment options enabled, that was not the problem.

 

Also, I am not going to say how I fixed it because I am (as mentioned before) a moron.

 

Thank you.

Link to comment
Share on other sites

I apologize for not posting my fix for my problem. Out of respect for the community I will now rip all cool points away from myself and forever become the laughing stock of, well, myself.

 

I had been working on my cart all day and most of the night. I was working off of a localhost server on my PC and uploading it to my public server as I completed things off of my list of "To Do's"

 

I was testing everything out and for some reason the payment options were not displaying on the public server (just the localhost). I destroyed everything on the public server. I tore apart everything I had updated. I dropped my DB and created a new one.

 

FINALLY, after two hours of doing that, I clicked next...to the part that said "payment options."

 

It turns out that I was on two different pages. On my localhost I was on the Payment Options Page (2nd Page) and Shipping Options (1st Page) on my public server.

 

I did the only thing I could do and laughed...drank beer...cried.

 

My only suggestion to you is that after trying to research this on the forums you should try to check and see if you have a bigger quantity for your product other than 0. That will can cause payment options to dissapear. At least that is what I read in someones post. Other than that, I am afraid I can offer no other advice other than to take a break when you are too tired.

 

Good luck.

Link to comment
Share on other sites

Thank you for the reply! Unfortunatly this is not the problem I have although I am updating across multiple servers with multipe installs. I can assure you I have done what you have done quite often and even dumber things as well ;)

 

I also checked the quantity and made sure the was a price in there as well but I still get no options during a check out.

 

I really don't want to have to re-install *again* and add everything back in. It worked Fri before I left work <_<

Link to comment
Share on other sites

My only real suggestion at this point would be to uninstall the language files you installed earlier. If you are the same person who created that other post.

 

It shouldn't be too hard but it is worth a shot. Go back one step at a time, that's what I do. If that doesn't work proceed slamming your head against the desk.

 

Oh yeah, check your flat rate too. Set it to something other than 0 (if that is the case). I found a post saying something to that effect as well.

 

I'll look around for other things to try and help for you. Good luck!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...