Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Unable to CHMOD configure.php


siteplanet

Recommended Posts

Hello,

 

A couple of days ago I started receiving the following error on four of my OSC sites:

 

"Warning: I am able to write to the configuration file: /home/favorite/public_html/includes/configure.php. This is a potential security risk - please set the right user permissions on this file"

 

I am familiar with this error, but it surprised me because the last I knew, the file permissions for that file on both sites were 444 (no access). I haven't changed anything on these sites in the past couple of weeks, and now this error is there.

 

Anyways, I went and tried to CHMOD the configure.php files on each site back to 444. This fixed the problem on two of the sites, but on the other two, it literally will not let me change the user permissions.

 

I go into my FTP program (have tried several), CHMOD the file to no access, just like always. Then the FTP program says that file permissions have changed, but if I refresh, there is still owner read access on the file, and I still get the error.

 

Has anyone else had this problem? What could be causing it?

 

Anyone have any suggestions? I need to fix this asap.

 

Thanks,

 

-Matt

Link to comment
Share on other sites

Hi.

 

Can it be some missconfigure to the server, try to CHMOD to 777 first and then CHMOD to 444 if the server is deniyng you to change the permission because the file allready is write protected.

Link to comment
Share on other sites

I am experiencing the same error. I have changed from 755 to 644 with no change. I still have the error. I have tried to ChMOD to 777 and back to 444 with no luck. I still have the error on the site. I need help ASAP.

 

Thanks.

Link to comment
Share on other sites

some FTP-Programms do not change the CHMOD realy, like WS_FTP. It shows after changing the changed CHMOD, but it is not changed.

Try to get SSH access form your provider and use WinSCP3 (use Google to find WinSCP3)

 

Greetings

Helmuth

Link to comment
Share on other sites

Something has changed on the server because I have 2 oscommerce sites running and they both have the same problem. I had them change the permissions to 444 for me on one. Now I have no header logo. Shit what else is going to happen?????????

Link to comment
Share on other sites

I just encountered the same problem,

 

Warning: I am able to write to the configuration file ...... configure.php ....

 

first I tried to use my cpanel interface, File manager to find the configure.php

and change user permissions on it. But it was already set to only user write access; I thought that might be the problem (our site was hacked last week - I thought the biatch did it again, I had not done any changes) and even cut the user write access; but cpanel wouldnt let me change it. So I CHMODed it in WS_FTP (444) and evoila: the message disappeared.

 

I am using XP, user is on Linux.

 

hope this might help someone

Link to comment
Share on other sites

Sorry for not responding sooner...I haven't been able to log in here until just now.

 

My host just emailed me back and says they have set up something called a "jail shell" that makes it so that the host (or presumably whoever has root) has to go in and change the files to 444. It sounds like lots of hosts have started doing this.

 

Does anyone know how much of a security risk is it to just leave it on 644 (owner read only) and disable the error message?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...