Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Strange HTML render issue


jessethouin

Recommended Posts

This error is happening on several pages. The best way to explain the error is with code. Here's an example (from login.php):

 

PHP code:

<tr>
<td class="main"><b><?php echo ENTRY_EMAIL_ADDRESS; ?></b></td>
<td class="main"><?php echo tep_draw_input_field('email_address'); ?></td>
</tr>
<tr>
<td class="main"><b><?php echo ENTRY_PASSWORD; ?></b></td>
<td class="main"><?php echo tep_draw_password_field('password'); ?></td>
</tr>

 

HTML render:

<tr>
<td class="main"><b>E-Mail Address:</b></td>
<td class="main"><input type="text" name="email_address"></td>
</tr>
<tr>
<td class="main"><bPassword:</b></td>
<td class="main"><input type="password" name="password" maxlength="40"></td>
</tr>

 

(Notice the "bold" tag is missing the closing ">" for Password).

 

In the following pages, look for the word "Password" to be either present or missing (depending on the link):

 

http://www.thecocoatree.com/login.php will render as intended.

 

http://thecocoatree.com/login.php (no www.) does not render correctly.

 

https://ssl.perfora.net/thecocoatree.com/login.php (my shared SSL server) also does not render correctly.

 

All of these renderings and misrenderings happen in IE 6.0.2800.1106 on Windows 2K Pro.

 

BUT........

 

In Mac Safari 1.0 (v85.5) on OSX 10.2.8, only ssl.perfora.net is misrendered. The other 2 links work fine.

 

In Opera 7.1.0 Beta 1 build 388 on Redhat Linux 8.0, none of the links render properly.

 

 

 

WEIRD!! Anyone with info on this?

Link to comment
Share on other sites

Yep, that's it.

 

This workaround worked:

 

[email protected] @ 09/07/2003 16:40:28

There is an alternative solution if your server doesn't support .htaccess.

Simply add the following line at the beginning of /includes/application_top.php:

 

ini_set ( 'session.use_trans_sid', 0);

 

Found it at the link you posted. I guess the workaround to use depends on the type of server.

 

Thanks for your speedy and accurate reply, Matt!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...