Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HTML coding errors


Mark1

Recommended Posts

Can someone help me with the last 3 HTLM errors I have on my site?

 

Here they are, and I do not really know what to do about them.

 

1) Line 3, column 102: required attribute "TYPE" not specified (explain...).

...et/trustlogo/javascript/trustlogo.js'> </script>

 

The code on line 3: <head> <script language="JavaScript" src='https://secure.comodo.net/trustlogo/javascript/trustlogo.js'> </script>

 

 

2) Line 41, column 67: there is no attribute "BACKGROUND" (explain...).

...t" class="infoBoxHeading" background="images/boxes/information.gif" nowrap><f

 

The code on line 41: <td height="41" align="left" class="infoBoxHeading" background="images/boxes/information.gif" nowrap><font size="2.5em" face="jeep"><strong><big><b>  Products</b></big></strong></font></td>

 

 

3) Line 133, column 406: there is no attribute "BORDER" (explain...).

...uttons/button_quick_find.gif" border="0" alt="<font size="2.5em" fa

 

The code from line 133: <td align="center" class="boxText"><form name="quick_find" action="http://www.circuitrysolutions.com/advanced_search_result.php" method="get"><input type="text" name="keywords" size="10" maxlength="30" style="width: 172px"> <input type="hidden" name="osCsid" value="df0e0138d07e515d1b2c433854e12cb4"><input type="image" src="includes/languages/english/images/buttons/button_quick_find.gif" border="0" alt="<font size="2.5em" face="jeep"><strong><big><b>  Quick Find</b></big></strong></font>" title=" <font size="2.5em" face="jeep"><strong><big><b>  Quick Find</b></big></strong></font> "><br>Use keywords to find the product you are looking for.<br><a href="http://www.circuitrysolutions.com/advanced_search.php"><b><font size="2.5em" face="jeep"><strong><big><b>  Advanced Search</b></big></strong></font></b></a></form></td>

 

 

Any help in fixing these 3 problems would be GREATLY appreciated.

 

 

Thanks!

 

Mark

Link to comment
Share on other sites

The code on line 3: <head> <script language="JavaScript" src='https://secure.comodo.net/trustlogo/javascript/trustlogo.js'> </script>

 

The error (?) goes away when you start and end yr JS as follows:

<script language="JavaScript" type="text/javascript">

<!--

JS

// -->

</script>

 

2) Line 41, column 67: there is no attribute "BACKGROUND" (explain...).

...t" class="infoBoxHeading" background="images/boxes/information.gif" nowrap><f     

 

background is NOT an attribute from <td> and a real mistake.

Use CSS to put a background in a <td>

 

3) Line 133, column 406: there is no attribute "BORDER" (explain...).

 

That error depends on the HTML version you are using (indicating as yr DOCTYPE) when checking the validity of your page.

 

In version 3.2 is was valid to use border="0", in version 4.01 it's advised to use yr CSS to do that.

"If you're working on something new, then you are necessarily an amateur."

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...