Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Guest account + Autologin


JonoB

Recommended Posts

Hi,

I have installed the Guest account contribution (allows guest to checkout wihtout creating an account), which works fine. Amongst other things, this contribution places two files in the /catalog folder, namely login_pwa.php and login_acc.php, which are called from the /catalog/login.php file as follows:

 

<?php

if (PWA_ON == 'false') {

require(DIR_WS_INCLUDES . FILENAME_PWA_ACC_LOGIN);

} else {

require(DIR_WS_INCLUDES . FILENAME_PWA_PWA_LOGIN);

}

?>

</tr>

</table></td>

</tr>

</table></form></td>

<!-- body_text_eof //-->

 

I am also trying to install the autologon contribution (Autologon 1.5) which requires changes to be made to the /catalog/login.php file (amongst numerous other changes!). However, the changes that are required to be made by Autologon 1.5 to this file cant be made, as part of this file has moved to login_pwa.php and login_acc.php.

 

So, I tried to make the required change to login_pwa.php files directly, but when trying to logon, I get the following error message:

 

Parse error: parse error in /home/www/myphotof/catalog/includes/login_pwa.php on line 74.

 

My login_pwa.php file looks like this (lines 59-87):

 

<table width=\"70%\" border=\"0\" cellspacing=\"0\" cellpadding=\"0\" align=\"left\">

<tr>

<td class=\"main\">" . ENTRY_EMAIL_ADDRESS . "</td>

<td>" . tep_draw_input_field('email_address') . "</td>

</tr>

<tr>

<td class=\"main\">" . ENTRY_PASSWORD . "<br><br></td>

<td>" . tep_draw_password_field('password') . "<br><br></td>

</tr>

<?php // HMCS: Begin Autologon **********************************************************

if(ALLOW_AUTOLOGON != 'false') {

?>

<tr>

<td>

</td>

<td align="left" class="smalltext"><?php echo tep_draw_checkbox_field('remember_me','on', (($password == '') ? false : true)) . ' ' . ENTRY_REMEMBER_ME; ?></td>

</tr>

<?php }

// HMCS: End Autologon ********************************************************** ?>

</table>

<table width=\"30%\" border=\"0\" cellspacing=\"0\" cellpadding=\"0\" align=\"right\">

<tr>

<td align=\"center\" class=\"smalltext\">" . tep_image_submit('button_login.gif', IMAGE_BUTTON_LOGIN) . "<br><br>" . '<a href="' . tep_href_link(FILENAME_PASSWORD_FORGOTTEN, '', 'SSL') . '">' . TEXT_PASSWORD_FORGOTTEN . '</a>' . "<br></td>

</tr>

</table>

</td>

</tr>

</table>

";

 

Any ideas on how I can get around this problem? Thanks for any suggestions or help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...