Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Another Graphic Problem, Please help


djgizmo

Recommended Posts

Ok, after no one attempted to help me on my last graphic problem I was forced to delete and reintsall oscommerce completely.

 

Anyways, I'm still having the language icon glitch. litterally copy of the icon.gif in both english directories and still showed the UK one. So I had to add another english laguage code it US, and point it to the same dir. That worked. Is there a better way than that?

 

Also, I added a catagory but it doesn't show up on my Categories / Products page in the admin but does show up on the main screen?

 

Call me stupid but this isn't seeming so user friendly like everyon is telling me... Please help.

 

Also, I'm getting this error in the backup section

 

Warning: is_dir() [function.is-dir]: Stat failed for /scorch98.com/store/admin/backups/. (errno=13 - Permission denied) in /scorch98.com/store/admin/backup.php on line 356

 

Warning: is_dir() [function.is-dir]: Stat failed for /scorch98.com/store/admin/backups/.. (errno=13 - Permission denied) in /scorch98.com/store/admin/backup.php on line 356

 

Warning: filemtime() [function.filemtime]: Stat failed for /scorch98.com/store/admin/backups/. (errno=13 - Permission denied) in /scorch98.com/store/admin/backup.php on line 369

 

Warning: filesize() [function.filesize]: Stat failed for /scorch98.com/store/admin/backups/. (errno=13 - Permission denied) in /scorch98.com/store/admin/backup.php on line 370

Link to comment
Share on other sites

Looking at the errors, it would seem like you have a permissions problem with the backup directory. Does a store/admin/backups directory even exist?

 

You may also be looking at a configuration issue. Check your store/admin/includes/configure.php to see if any of the setting look incorrect.

 

-R

Link to comment
Share on other sites

If the directory exists, and you have the permissions set accordingly, than it must be a config issue.

 

Would you mind posting or PM me your admin config file? I have a feeling thats where the issue is.

 

-R

Link to comment
Share on other sites

Ok, heres my current config... Now when I go to my catalog it get no permission to view the catalog or the admin tool...

Some kind of Error 403.

 

Go figure?

 

Sean

 

P.S. would that 403 error be from my host or permissions set from the files in the catalog?

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright ? 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.scorch98.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.scorch98.com');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/WebSites/glowin-a-fuse/scorch98.com/store/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/store/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/WebSites/glowin-a-fuse/scorch98.com/store/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/store/'); // absolute path required

define('DIR_FS_CATALOG', '/WebSites/glowin-a-fuse/scorch98.com/store/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', '213.151.32.128'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'XXXX');//XXXX edited for my protections

define('DB_SERVER_PASSWORD', 'XXXX');

define('DB_DATABASE', 'XXXX');

define('USE_PCONNECT', 'false'); // use persisstent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

Nothing jumps out at me.

 

Questions...

Is this an IP-based site or a name-based site? meaning, does this site have a unique IP Address, or is it using a shared IP address?

 

Now, if its an IP-based site, when you FTP, are you connecting to the unique IP Address or the shared server IP Address?

 

-R

Link to comment
Share on other sites

Right now I'm not sure. I think its a shared IP address. Due to the nature of unlimted space/unlimted bandwidth...etc.

 

When I connect via FTP, I use www.mysitename.com for address in the ftp program.

 

I hope that gives you some more info...

 

Also, why would I get a 403 permission error?

 

Sean

Link to comment
Share on other sites

Make sure that the Directories also have correct permissions, which should be 755.

 

The reason I asked about the site being IP-based is there is a known bug when connecting FTP to the actual site IP Address when the site is IP-based. The permissions of the uploaded files are random at best. This sounds somewhat similar to your issue, thats why it came to mind.

 

-R

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...