Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Verisign issue


jameslong

Recommended Posts

Hi All,

I have implemented verisign payflow link and almost everything is ok, however there is one problem.

After the payment is processed and the customer clicks on the button to return to shopping on my site, they have to log back into the system which is not a good thing.

Does anyone know a way to stop the customer from being logged out when returning to the site after the payflow link payment?

 

I have set the following up in the payflow link manager:

 

Return URL: https://secure.mydomain.com.au/checkout_success.php

 

Silent post URL: https://secure.mydomain.com.au/verisignreturn.php

 

Any assistance or ideas are appreciated.

 

Regards,

James

Don't forget to check out http://wiki.oscommerce.com/Top for OsCommerce support documentation

Link to comment
Share on other sites

You might try changing the code around a bit so that it opens a new window when sending the customer to the other site. The problem is probably that the other site doesn't send a session ID with the customer when they return. If you open another window then they will not need to return and will just need to make sure that they close the window when completed.

 

I'm mostly talkin out my arse on this one tho, since I've never used payflow and I'm not familiar enough with the osC source (nor have it with me at the moment) to give you an example.. But that's where I would start if in your shoes.

 

G'luck.

Link to comment
Share on other sites

Hi

I thought of that approach by adding some code to bring up a new window (the verisign box) when a customer confirms the order, but this poses a few problems and I need a streamlined checkout process to avoid confusion.

 

Any ideas are appreciated.

 

James

Don't forget to check out http://wiki.oscommerce.com/Top for OsCommerce support documentation

Link to comment
Share on other sites

  • 3 weeks later...

jameslong,

sorry i don't have a solution to your problem, but I am having a huge one. We are going live in a couple of hours & I can't get Verisign to work! Did you write your own payment module or use the payflo pro module in the contributions section? I can't get the contrib to work properly. Of course I am using a hosting company and am not running the store off my own server. Any help would be greatly appreciated. You can email me at [email protected] Thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...