Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

I AM A NOVICE AND NEED HELP DESPERATELY!


Guest

Recommended Posts

:blink:

 

I am brand new to this and trying to get a web site up and running with an OS Commerce shopping cart. I can't seem to get images to load. Please help! Thanks so much :)

Link to comment
Share on other sites

Is there anyone who can "walk me through" the OS Commerce setup? It says my images have to be in the same drive/directory, but I don't know how to do that. Thanks!

Link to comment
Share on other sites

I am brand new to this and trying to get a web site up and running with an OS Commerce shopping cart. I can't seem to get images to load. Please help! Thanks so much

 

:ph34r: Please Check your Configure.php , and make sure the paths are correct,

 

and is true that you have to help us help you, by explain the situation details.

If life get to hard in front of you! Just move to the side and let it pass thru....then go back and make the experience a leason to you

Link to comment
Share on other sites

So sorry to be vague. I am receiving the following messages when I try to add an image for my product:

 

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/patriotd/.panel/web/ecommerce/os/admin/includes/functions/database.php on line 39

 

 

The page also says: NOTE: To upload or remove images, make sure the catalog/images directory has WRITE permission for the user that runs your Apache process (eg, nobody). This can be made by executing the following commanda:

 

cd catalog

chmod -R nobody.nobody images

 

but I don't know where to put this command.

 

Thank you again!

Link to comment
Share on other sites

And it meant that if you have command line access to your server, meaning you can hook up to it in the seemingly intimitading mode where it just gives a promt, but not a windows like box, you would type cd catalog, press return, type the command and press return again. Jeremy

Link to comment
Share on other sites

Hi Jeremy, and thanks.

 

Both of your answers make sense, but when I go to the catalog/images directory, right click, it doesn't give me any options to change attributes. It just gives me the .gif information.

 

Likewise, I understand what cd catalog means, but I can't find where the command line would be to type it in.

 

Thank you again.

Link to comment
Share on other sites

Hi,

 

I think Jeremy means you will need to either

 

1. Change the permissions of the folder using your FTP client. (try right clicking on the images folder and see if chmod is in the list)

 

or

 

2. Using your host (cpanel or whatever file admin software they have) go to the images folder and look for place to change permissions.

 

I thought in the setup directions it says to change to 777, but I could be wrong on that.

 

hope that helps, :)

Phil

Link to comment
Share on other sites

Thank you so much, and I apologize for my ignorance, but I truly am a novice. I have found several folders that say "images". However, none of them give me options. FYI, I am the web site administrator (now THERE's a problem, ha ha!) by default, as this is a family-owned site, and I am the most computer-literate :blink: I am knowledgeable about some things, but not this stuff.

 

As for FTP, are you speaking of (for instance) WS-FTP95? If so, when I open WS-FTP and connect to my web site home page, I can find no place where I can make changes to permissions and/or attributes.

 

Thank you.

 

Lyn

Link to comment
Share on other sites

You open up your ftp program and connect to your site. You should now be able to navigate uo and down through the folders to find all the files and folders right? So you want the images folder, you want to right click on it, not so that it opens, but so that a menu pops up with options starting with open, run as, blah, blah, and at the bottom of the list there should be properties. You open that, and on the first page, at the bottom there should be an attributes section. Depending on the OS you're using you can set it as a number to 755 or 777, or you can check or uncheck boxes, and if so ,make sure read only is not checked. Jeremy

Link to comment
Share on other sites

When you installed your site and opened it for the first time, you should have had a red banner up top with the error message telling you that the program could write to the configure.php files. That's exactly the same thing we're dealing with here, except instead of removing the ability to write to a file, you're enabling the ability to write to a folder. Jeremy

Link to comment
Share on other sites

Just somethign that may help, you may want to look for a program called Smart FTP... I got my version from download.com and you can do a search for it there... I use that program to change the file permissions by right clicking on the desired file, and look for CHMOD or simply use the F7 key after selecting the file... and that will bring up the chmod menu and it's pretty straight forward from there... Also just to help you find the file if it works for you you can find the installer @ my site... here's a link to it... smartFTP download Good luck!

Link to comment
Share on other sites

Thank you so very much! I finally figured it out, thanks to your help. And thanks to everyone who took their precious time to reply. I have been "messing" with this for a month now, and would still be in the dark with no one to give me tech support, so you have really REALLY made my day! Thanks again.

 

Lyn

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...