Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Getting Images to Upload


shaneishandome

Recommended Posts

Oscommerce Admin: http://www.getcertifiedtexas.com/catalog/admin/index.php

(this is just a test so I dont care if it gets messed with)

 

I recently installed Oscommerce and I have come across a problem. I am unable to upload any images at all. The error is the following

 

Warning: open_basedir restriction in effect. File is in wrong directory in /home/.macintoshdryer/sjaw/getcertifiedtexas.com/catalog/admin/includes/classes/upload.php on line 93

 

Warning: Cannot add header information - headers already sent by (output started at /home/.macintoshdryer/sjaw/getcertifiedtexas.com/catalog/admin/includes/classes/upload.php:93) in /home/.macintoshdryer/sjaw/getcertifiedtexas.com/catalog/admin/includes/functions/general.php on line 18

 

My /catalog/images/ directory is at 777

 

My config for images is /catalog/images/

 

I checked to see if there is an extra space on both upload.php and general.php. Both seem to be ok. Does anyone have any ideas?

 

Please help and I thank you.

 

Shane

Link to comment
Share on other sites

Try setting upload_tmp_dir in php.ini, httpd.conf, or .htaccess. For .htaccess, the code would look like

php_value upload_tmp_dir /home/sitename/htdocs/catalog/temp/

You might have to create a temp directory (and chmod it to 777) to get this to work. Change /home/sitename/htdocs/catalog/ to match the DIR_FS_CATALOG value from includes/configure.php

 

Hth,

Matt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...