Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Easy Populate..


Recommended Posts

I've read through all of the instructions and have manually split the file into two files (first 200 records, second 203 records).


I don't get any error messages.. After I try to import the first file, I get...


File uploaded.

Temporary filename: /var/tmp/php4f2sUX

User filename: pfizco-ep.txt

Size: 26127


But nothing appears in the store (no items/products). So, what could I be doing wrong??


Is my database (TAB delimited file) incorrect?? Am I missing something (a process or something)??


Thanks in advance..



Link to comment
Share on other sites

Tried the EP Split function, but it said ...


Creating ???? (file)

0 records added...


Tried three times and figured I would do it myself..


I also noticed that the sample EP database did not match the one I downloaded from the store (using ep). So I converted everything again and am trying it now...


Any assistance would be appreciated??



Link to comment
Share on other sites

Here is the exact information from the "split routine"...



Easy Populate 2.62-MS2 - Default Language : English(1)

Creating file EP_Split1.txt ... Added 0 records and closing file...


You can download your split files in the Tools/Files under /catalog/temp/



By chance do I have to change the permissions of the temp directory??


And why is EP still saying "catalog/temp/"?? I changed it in the code to "/store/temp/".



Link to comment
Share on other sites

Here is the whole process...




File uploaded.

Temporary filename: /var/tmp/php7EIA18

User filename: EP2003Nov11-1010.txt

Size: 50847


Notice : nothing in TEMP directory.


Split EP File


Creating file EP_Split1.txt ... Added 0 records and closing file...


You can download your split files in the Tools/Files under /catalog/temp/


Notice : nothing in TEMP directory.




Notice : nothing in TEMP directory.

Link to comment
Share on other sites

  • 1 month later...

Can you show me the column name in your .TXT file? I don't need to see the data, just the column names. (This should be the very first row of your spreadsheet)


I may be able to look at this and help you with your problem. I had the same, and have since been able to correct it, but it is not just a "here's the answer" sort of thing. Usually, the problem lies in the column names not matching up exactly as they should.


Also, did you do and SQL to add all of your own additional columns to your database? You have to do this for EP to find the correct tables to add your data to.


You can email me if you like at tom@campbundy.com, and I'll try to help.


Tom B)

Link to comment
Share on other sites

i got it to work, i just downloaded the file and made changes there, now the question is adding another field called retailprice v_products_retail_price

what do you think?





v_products_model v_products_image v_products_name_1 v_products_description_1 v_products_url_1 v_products_name_2 v_products_description_2 v_products_url_2 v_products_name_3 v_products_retail_price v_products_retail_price v_products_url_3 v_products_price v_products_weight v_date_avail v_date_added v_products_quantity v_attribute_options_id_1 v_attribute_options_name_1_1 v_attribute_options_name_1_2 v_attribute_options_name_1_3 v_attribute_options_id_2 v_attribute_options_name_2_1 v_attribute_options_name_2_2 v_attribute_options_name_2_3 v_attribute_options_id_3 v_attribute_options_name_3_1 v_attribute_options_name_3_2 v_attribute_options_name_3_3 v_attribute_values_id_3_1 v_attribute_values_price_3_1 v_attribute_values_name_3_1_1 v_attribute_values_name_3_1_2 v_attribute_values_name_3_1_3 v_attribute_values_id_3_2 v_attribute_values_price_3_2 v_attribute_values_name_3_2_1 v_attribute_values_name_3_2_2 v_attribute_values_name_3_2_3 v_attribute_values_id_3_3 v_attribute_values_price_3_3 v_attribute_values_name_3_3_1 v_attribute_values_name_3_3_2 v_attribute_values_name_3_3_3 v_attribute_values_id_3_4 v_attribute_values_price_3_4 v_attribute_values_name_3_4_1 v_attribute_values_name_3_4_2 v_attribute_values_name_3_4_3 v_attribute_values_id_3_5 v_attribute_values_price_3_5 v_attribute_values_name_3_5_1 v_attribute_values_name_3_5_2 v_attribute_values_name_3_5_3 v_attribute_options_id_4 v_attribute_options_name_4_1 v_attribute_options_name_4_2 v_attribute_options_name_4_3 v_attribute_values_id_4_1 v_attribute_values_price_4_1 v_attribute_values_name_4_1_1 v_attribute_values_name_4_1_2 v_attribute_values_name_4_1_3 v_attribute_values_id_4_2 v_attribute_values_price_4_2 v_attribute_values_name_4_2_1 v_attribute_values_name_4_2_2 v_attribute_values_name_4_2_3 v_attribute_values_id_4_3 v_attribute_values_price_4_3 v_attribute_values_name_4_3_1 v_attribute_values_name_4_3_2 v_attribute_values_name_4_3_3 v_attribute_values_id_4_4 v_attribute_values_price_4_4 v_attribute_values_name_4_4_1 v_attribute_values_name_4_4_2 v_attribute_values_name_4_4_3 v_attribute_options_id_5 v_attribute_options_name_5_1 v_attribute_options_name_5_2 v_attribute_options_name_5_3 v_attribute_values_id_5_1 v_attribute_values_price_5_1 v_attribute_values_name_5_1_1 v_attribute_values_name_5_1_2 v_attribute_values_name_5_1_3 v_attribute_values_id_5_2 v_attribute_values_price_5_2 v_attribute_values_name_5_2_1 v_attribute_values_name_5_2_2 v_attribute_values_name_5_2_3 v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_tax_class_title v_status EOREOR



do you think i should put the retail price in the begining?



Edited by monterey93940
Link to comment
Share on other sites

i got it to work !!


i get different error

File uploaded.

Temporary filename: /tmp/phpWs1oDv

User filename: EP2004Jan12-1806.txt

Size: 841

| 1 | | 12th | this is th | | 35 | 12 | | 1/12/2004 | 20 | | Fragrances | | | 45 | --none-- | Active Updated

| 20 | sm_ANUCCI_ | third | this is th | | 15 | 20 | 1/12/2004 | 0000-00-00 | 20 | Calvin Kli | Fragrances | Women's | | 45 | Taxable Go | Active Updated

| 3 | | one | hello | | 20 | 20 | 1/12/2004 | 0000-00-00 | 20 | Calvin Kli | Fragrances | Women's | | 100 | Taxable Go | Active !New Product!

1136 - Column count doesn't match value count at row 1


INSERT INTO products ( products_retail_price, products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( '', '3', '20', '1', CURRENT_TIMESTAMP, "0000-00-00 00:00:00", "1/12/2004 1:17", '1', '20', '20', '100' '10')

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...