Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

URGENTLY HELP NEEDED - Order/Admin problem


mlowrey

Recommended Posts

hi guys,

 

i'm really having a big problem, i suddently don't see my orders/new orders anymore in my admin. i only see: ( pending: 2 in the menu ) but i don't see the records with all the data and the order from the customer.

 

When i log in to my mysql database, then i do see the data in de mysql database................

 

can someone help me with this.............. i really don't know what to do.......

 

thx mike

Link to comment
Share on other sites

I have the very same problem, I have not added any modules. For payment I am using the cc/email. Not a payment gateway.

 

Any suggestions? I can login as a customer an view my information, but when I'm logged in as admin that data is not displaying.

 

The other thing I noticed is that while I have a certificate for orders (security) when I login to the admin, I'm not logging in securely. Would this have any effect? and how do I use ssl for the admin?

Link to comment
Share on other sites

Same problem here, just realized it today to.

 

The main problem is, I don't have a working back-up and I don't know when it started. I usually don't make a complete purchase when I'm testing everything out.

Link to comment
Share on other sites

I have deleted:

 

and ot.class = 'ot_total'

 

in orders.php and that seems to show the orders in Admin, but still doesn't show when I log in as a customer.

 

Also, in admin the 'Order Total' isn't displayed as a result of the 'orders_total' table being empty.

 

Anyone have any idea what would be causing this or have a fix?

Link to comment
Share on other sites

Sorry about the repetative posts, but I thought I would just post about how I finally fixed mine.

 

I went through everything I could find, spent about 6 hours working on this with no luck. I finally just gave up and was screwing around in Admin when I decided to simply uninstall and re-install all the payment, order total, and shipping modules. It worked!

 

The solution may be as simple as this for some of you or not, it's worth a try!

 

Dave

Link to comment
Share on other sites

hi ,

 

txh for helping,

 

but i do see the customer profile. But what i don't see is what the have ordered, the order screen in the admin is empty. It only shows the number of orders in the main admin menu , like this: Pending: 3. But when i click on pending 3 then it shows no records/data.

 

This problem showed up, without any big modifications done by me. All the other things do work. very strange.

 

I hope that someone has a solutiion because this is really irritating me.

 

THX Mike.

Link to comment
Share on other sites

Have you tried any of the fixes mentioned in this post aswell as other posts?

 

Please post what you have all tried. Can't suggest anything unless I know what you have all done already.

 

-Dave

Link to comment
Share on other sites

Lessliquidation?

 

Have you tried doing the module reinstllation if they have Been modded?

 

I am having the same problem, and I dont want to lose the modifications I have made to the display but sheesh, not having orders show at ALL is about 10 times worse.

One of these days, I will actually understand what I just changed...

 

But reading the Manual DEFINATELY helps...

Link to comment
Share on other sites

I have deleted and re-installed the modules on this via the admin console. I still cannot see customer information if I click on "customer." If I login as a customer, I see my information correctly. Anyone else still having a similar problem or have any input?

 

Thanks.

Link to comment
Share on other sites

May have found a fix. Although, it appears maybe the db update has worked. Our DBA has done a couple of things, but I'm not sure what actually served us.

 

The orders would come through correctly, but shipping address, etc. would not display when viewing orders.

Link to comment
Share on other sites

  • 3 weeks later...

One fix that use to work for me but is not working this time around is to do the following.

 

Login into MyPHP and go to the Orders_Status table and change Order_Status_Id from '0' to '1'.

 

My problem right now is that my Order_Status_Id is already set to '1' and I'm still not getting any recent orders made displayed in my admin section.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...