Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

SSL Help


xecutech

Recommended Posts

I tested my shop and everything worked fine. I installed a shared ssl and now customers don't stay logged in, shopping carts are empty after login and etc.

I am sure that this is due to a setting in config.php, but I am not sure what's wrong.

 

This site is now live, go check it out and set an account and etc. and try shopping and you will see what I am talking about.

 

http://www.jettink.com

 

I need this corrected today. Please help.

 

Thank you,

Tom

Link to comment
Share on other sites

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

 

This is what it shows in config.php

Link to comment
Share on other sites

I took a look, nad it acts as you've described.

 

What contributions have you installed since it last worked?

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

I have not added any contributions. This only started after I started using ssl.

 

If any of you are using a shared ssl with oscommerce, what settings do you have in config.php? Is there any other files that needed to be changed after I started using ssl?

Link to comment
Share on other sites

define('HTTP_SERVER', 'http://www.jettink.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://secure9.dnsvelocity.com/~jettink/'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.jettink.com');

define('HTTPS_COOKIE_DOMAIN', 'www.jettink.com');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

Link to comment
Share on other sites

Hi,

 

Remove the last forward slash.

 

define('HTTPS_SERVER', 'https://secure9.dnsvelocity.com/~jettink'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

 

I just looked at your site and you can see the // two forward slashes in the url:

https://secure9.dnsvelocity.com/~jettink//catalog/login.php?

 

When you remove that last one like above I think it will work.

Link to comment
Share on other sites

Hi,

 

I setup a test account. It keeps taking me back to the login page whenever I try to check out.

 

Did you change the admin/includes/configure.php file also?

 

Do this.

 

Make sure in both configure.php files you have removed the last forward slash on http and https settings.

 

Make sure in both configure files you have sessions stored in mysql at the bottom of configure.php files.

 

In the admin turn off cache if it is on.

 

In admin set all configuration/settings to false.

 

Try it then.

Link to comment
Share on other sites

Are you sure you do not have Ian's 'SID Killer' contribution installed?

 

This is the exact behavior of that contribution.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

I have no contributions. My admin config.php files were not set, so I think we are getting close, but it still logs me out. I am trying what Melinda suggested. I will check back in a minute.

Link to comment
Share on other sites

I made all the changes that you suggested and it is still acting funny. Could this be a cookies problem? Should I toggle forced cookies?

 

define('HTTPS_COOKIE_DOMAIN', 'www.jettink.com');

 

should this be my secure address instead?

Link to comment
Share on other sites

Do you have forced cookies turned off?

 

I don't know what your domain is for your ssl.

 

Can you install your own ssl? If so, I would certainly recommend that.

Link to comment
Share on other sites

I would try toggling 'Force Cookies" to verify that it's a session problem.

 

I'm not ceratin about the https cookie server setting.

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

I could never get OCS to work properly on a shared cert. I got my own and life has been happy ever since.

 

I had a few posts about it, maybe check them out. I think one of em had a revelation where I figured something out but I forget what it was.

Link to comment
Share on other sites

THANK YOU MATTI!!!!!!!!!!!!!! I think that did it.

I was wondering about that line of code and I did try that, but when I did I set all of the settings that made reference to https in it. I never tried it one line at a time.

I just did a quick test with it and all seemed fine.

Again, Thank you.

-Tom

Link to comment
Share on other sites

Yeah, that's a problem with that contribution that we never got around to solving.

 

Use the 'Spider Killer'

-------------------------------------------------------------------------------------------------------------------------

NOTE: As of Oct 2006, I'm not as active in this forum as I used to be, but I still work with osC quite a bit.

If you have a question about any of my posts here, your best bet is to contact me though either Email or PM in my profile, and I'll be happy to help.

Link to comment
Share on other sites

  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...