Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Language customization


lalev

Recommended Posts

I think you need to change the line

 

setlocale(LC_TIME, 'en_US.ISO_8859-1');

 

in languages/<whatever>.php

 

You might also need the locale installed on the web server.

 

I'm not an expert on this, so the above could be total rubbish. If it is, please tell me.

Link to comment
Share on other sites

setlocale should work, but there is a post explaining how to replace the English months manually around here somewhere. I think that it might have been posted by Meltus.

 

Hth,

Matt

Link to comment
Share on other sites

What I have here is server problem... I tried so manu things to change it... but it did not work at all...

Anyways... there is a link to a post that might help:

 

Oh God, why my server? Why?? by Musashi-kun

That explains how to substirute/replace the displayed text for the month name when the server does not have your own language...

 

And there is a link to a setlocale subroutine parameters:

Setlocale Parameters

 

And for all that might need the Bulgarian one there it is:

@setlocale(LC_TIME, 'bg_BG.ISO8856-5');

 

And another one again in Bulgarian that I used for linux server was:

@setlocale(LC_TIME, 'bg_BG.CP1251');

 

So try to find out whether the server has your language...

Then try to find the @setlocale parameter for that server...

And if that still does not work go to the Oh God, why my server? Why?? topic...

 

I hope that helps people that are looking for solvation of the problem so that they not spent so much time browsing thru the forum...

 

;)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...