Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Email problem, cant go live


mcoski

Recommended Posts

Return-path: <[email protected]>

Received: from nobody by sv1.modernvisions.net with local (Exim 4.24)

id 1ADnGo-0006Ui-0J

for [email protected]; Sun, 26 Oct 2003 07:57:34 -0800

To: "Michael Chang" <[email protected]>

Subject: Order Update

From: "Michael Chang" <[email protected]>

MIME-Version: 1.0

X-Mailer: osC mailer

Content-Type: text/plain; charset="iso-8859-1"

Content-Transfer-Encoding: 7bit

Message-Id: <[email protected]>

Date: Sun, 26 Oct 2003 07:57:34 -0800

 

 

Here is the header I get from the bounced email. Let me know if you can help me out please, I need to resolve this problem within the next day or two. I tried using the SMTP authentication contribution with no luck still. My hosting company says that it may be a problem with oscommerce, and from looking and searching on the boards it seems that it could be a problem with the server not wanting 'nobody' logins to send emails to reduce spam. Here are my sendmail :

 

sendmail_from no value no value

sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i

SMTP localhost localhost

smtp_port 25 25

 

I tried both send mail and smtp but no luck. It does however send a copy of the email to my email using the webserver but the hotmail (testing account) does not receieve it.

 

I also tried the ini_set(sendmail_from, "[email protected]"); setting but it doesnt seem to help at all. What should I set the nulls in

sendmail_from no value no value

to? Should it be 'localhost' 'txcpu.com 'smtp.txcpu.com' 'http://www.txcpu.com' etc?

 

Thanks for the help guys! I need to get this resolved asap!

 

p.s. The server is shared webhosting (not dedicated server for me) so i have no access to php.ini, thanks!

Link to comment
Share on other sites

what type of server is it? *nix or winbox?

*Outlined in chalk everone looks the same*

 

Currently useing OSC 2.2 MS1

running on Apache/1.3.27 (Unix) (Red-Hat/Linux) mod_jk/1.2.0 mod_perl/1.26 PHP/4.3.3 FrontPage/5.0.2 mod_ssl/2.8.12 OpenSSL/0.9.6b

Link to comment
Share on other sites

sendmail_from is for MS Windows boxes and SMTP. What you want to do is add -f [email protected] (substitute real email address) to your sendmail_path line, like this:

/usr/sbin/sendmail -t -i -f [email protected]

If that doesn't work for some reason, try '[email protected]' instead. Note: only sendmail_path matters among those vars. The others are for MS.

 

Make sure that your line feed is set to LF. Unlikely to be the problem but should be eliminated.

 

As they think it may be a problem with osCommerce, suggest to your host that they give you a working email script that generates a short email to your hotmail account. If they can do so, post the script here so that we can see what it does. I suspect they can't, because they have exim set up to treat this as a relay attempt.

 

If other users (not nobody) can send email, they could fix this by adding a setuid (to someone who can send mail) script:

#!/bin/sh

(while read line
do
 echo $line
done) | /usr/sbin/sendmail $*

Then you could change the sendmail_path to point to that script and it should work.

 

After that, my best suggestion is to switch hosts.

 

Hth,

Matt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...