Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

How do I change url reference of OSCsid


Guest

Recommended Posts

Change how?

 

From admin > Configuration > Sessions > Force Cookie Use, you can set to true to remove the session ID from all URLs. It is actually added in the tep_href_link function in includes/functions/html_output.php

 

Hth,

Matt

Link to comment
Share on other sites

If you remove the session ID without storing it in a cookie, then you will not be able to carry information from page to page. Thus, customers will not be able to log in and purchase things.

 

You could check out the SID/spider killer contributions. They kill the session ID for various user agents (googlebot, etc.).

 

Hth,

Matt

Link to comment
Share on other sites

I do not want to remove it of course. But I hope it should be possible, somewhere in the code, to choose between the POST and GET methodes of sending session ID from page to page.

 

A friend of mine has obtained a bit modified version of osC. It works as I say: session ID unvisible, however (I checked it several times and I am 100% sure) cookies are NOT forced in the admin panel.

 

I also installed it on my server. The result is the same. Please take a look here. Unfortunately we do not have contact with the author of the changes. I tried to compare carefully this verion to a standard one, but I couldn't find any difference, as far as handling osCsid is concerned.

Link to comment
Share on other sites

Interesting.... Now with the forcing of cookies I cannot login, even when my privacy settings are set to accept all cookies. Tried with different browsers all giving me the same results. Whats the deal?

Link to comment
Share on other sites

Probably your advise was not directed to me but it seems it solved my problem. In fact the file configure.php was the only one different between the two osC applications. In the 'wrong' osC with session ID displaed in the url the settings in configure.php were just standard: ('localhost' etc). After I replaced them with real addresses and values I got what I was lookig for.. Thank you!

Link to comment
Share on other sites

hello matt,

below are the configure.php details requested:

define('HTTP_SERVER', 'http://www.mydomain.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', false); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'http://www.mydomain.com/');

define('HTTPS_COOKIE_DOMAIN', '');

define('HTTP_COOKIE_PATH', '/store/');

define('HTTPS_COOKIE_PATH', '');

define('DIR_WS_HTTP_CATALOG', '/store/');

define('DIR_WS_HTTPS_CATALOG', '');

Link to comment
Share on other sites

I've got the same problem and it occured in the admin links too so I had to go to the table configuration and change the field manually from false to true.

now those oscid....lines don't exist anymore in the shop but they still are in the admin part and I can't configure the site.

brand new in php/mysql....please help an old artist lady. (53 and painter it's hard to start making my brain work again!!!!!-joke)

anyway pleeeeeaaase heeelp me. I'm blocked :blink:

The only thing I know is that I don't know anything.....

but I learn

Link to comment
Share on other sites

Is the .htaccess working otherwise? Other than that, I don't know. I've never had this much trouble with cookies before this. Maybe I'm just missing a setting.

 

Good luck,

Matt

Link to comment
Share on other sites

yes htaccess is working otherwise, ie for redection, ip blocking , passwords, etc...

I will go through my Admin>Configuration>sessions settings in more detail.

----

Session Directory: /tmp

Force Cookie Usage: True

Check SSL session ID: false

Check user agent: false

Check ip: false

Prevent Spider session: false

Recreate session: false

 

- Are settings meant to be changed elsewhere in admin for cookie usage?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...