Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

HELP my site is screwed up!?!?


Guest

Recommended Posts

sorry i have you the site so you could look at the code that was messed. Heres some more info : i was installing the newdesk script. All i did was add orchange three files which i have already changed back. and uploaded more. now it give me the errors you see

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /var/www/html/catalog/includes/application_top.php on line 291

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/php/includes:/usr/share/php') in /var/www/html/catalog/includes/application_top.php on line 291

Link to comment
Share on other sites

Seems to be looking for something that isn't there. If you had it working before you made the changes then you must be able to make it work again provided you have the original files that worked, even if you backup your database and reinstall the whole thing (it doesn't take long). The golden rule is always to back everything up regularly because anyone can inadvertently do something that messes things up without maybe knowing what it was.

 

My general point was that a good question is one that gives enough information for someone else to suggest an answer, otherwise it's pointless guesswork even if one knows what one is talking about.

 

Regards,

 

Patrick

Link to comment
Share on other sites

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /var/www/html/catalog/includes/application_top.php on line 291

 

What does the block that line 291 in application_top.php say

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/php/includes:/usr/share/php') in /var/www/html/catalog/includes/application_top.php on line 291

 

Looks like a file is missing - But I am probably wrong :huh:

 

regards

 

mark

Regards

 

Mark A Reynolds

Link to comment
Share on other sites

The last time that I saw this error, it was caused by a failed database upload. Check the configuration table (in the database). In particular, you want to see a setting for default language (probably listed as something like DEFAULT_LANGUAGE). Note: if that's the problem, then this is just the tip of the iceberg.

 

If that's not it, you could try adding

if (!tep_not_null($language)) $language = 'english';

(or whatever language) before line 291 (which will say something like require(DIR_WS_LANGUAGES . $language . '.php');). This should get you past this specific error. If there are other problems, it may just get you to a different error.

 

Hth,

Matt

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...