Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Problems with E-mail related functions


Guest

Recommended Posts

I'm not sure what I have missed but anytime I try to:

1) Create an account (it creates it put shows the error on the site)

2) When I place an order (final order confirmation page - order is actually recorded it just shows the error on the site)

3) Send mail via the Contact Us form (doesn't send the mail although I can send a product referal to a friend and get my password reset via e-mail just fine)

 

Error:

Warning: Cannot add header information - headers already sent by (output started at C:\OpenSA\Apache\htdocs\catalog\includes\classes\email.php:500) in

 

C:\OpenSA\Apache\htdocs\catalog\includes\functions\general.php on line 29

 

I'm thinking this is something simple like a configuration setting but I can't seem to find it.

 

Anyone else who has had this problem or knows how I can fix it please respond with it's info.

 

THanks in advance,

Link to comment
Share on other sites

Well I tried that and it didn't work. It gave the following error:

Warning: Failed to Connect in C:\OpenSA\Apache\htdocs\catalog\email_test.php on line 15

 

Warning: Failed to Connect in C:\OpenSA\Apache\htdocs\catalog\includes\classes\email.php on line 500

After further reviewing the files and such I'm think it may be contributed to the oscommerce application not knowing what to display to confirm the action has been completed.

 

I'm at a loss, anyone else have any idea for me to try?

 

Thanks in advance....

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...