Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

WorldPay error: no callback - please help.


tigertom

Recommended Posts

I have installed *both* Oscommerce MS1 and MS2 and the latest Worldpay module.

I have inserted my WorldPay ID in the Worldpay module, and http://<wpdisplay item="MC_callback"> in the Worldpay admin page.

 

Added my email address in the cart config page.

 

Added define('FILENAME_WPCALLBACK', 'wpcallback.php'); to catalog/includes/filenames.php

 

A test purchase at Worldpay goes through, but does not return to the cart, hence I get no emails from it. I just get this message on-screen from WorldPay:

 

"This was NOT a live transaction - no money has changed hands

Thank you, your payment was successful

Merchant's Reference: osCsid=c804d31763d822f9a66d68dbbf6d8fb5

WorldPay Transaction ID:?50445811"

 

 

I get an email from Worldpay, and that's it. Please help. I'm pig sick of trying to get this to work. Thanks.

Link to comment
Share on other sites

I am having the same problem ;) :(

 

 

I receive:

 

This was NOT a live transaction - no money has changed hands

Thank you, your payment was successful

Merchant's Reference: osCsid=db76f0d92969683ae4614e37910df078

WorldPay Transaction ID: 51320756

 

Please contact WorldPay immediately if there has been a problem making your payment.

 

---------

 

and it doesn't go back to the OsCommerce Store...

 

Anyone have ideas .... I fairly certain I followed the install instructions..

------------------------

Chief Web Developer

http://Canfone.com

https://SecureLogoHosting.com

Link to comment
Share on other sites

In admin, go to modules > payment and then to 'Secure Credit Card Payment'. Set your mode to 0, as it is currently set to test mode (100). Also, you must get Worldpay to change your account to live mode.

 

I am also having a problem with the worldpay mod. I make an order and the money gets transferred, but no order comes up in the admin area. I have Processing, Pending and Delivered in place. Any Ideas?

I've noticed that some peoples carts redirect back to the home page. Have you manually set a redirect meta tag?

 

Thanks in advance,

Frank

Link to comment
Share on other sites

  • 3 weeks later...

Have any of you bothered using the ResultC and resultY.html files? or do they not need to be used?

 

I still cannot get my site to go back to my os-commerce store :(

 

can anyone help?

cheers

Ant

www.gadgetworldonline.com

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

GadgetWorldOnline - A Whole World of Gadgets

www.gadgetworldonline.com

 

Tel. +44(0)161 612 2268

E-mail. [email protected]

Link to comment
Share on other sites

  • 1 month later...

I am having the same problem, I have enabled callback with worldpay and the payment gets through fine till I get:

 

Thank you, your payment was successful

Merchant's Reference: <shopname> : <customer name>

WorldPay Transaction ID: <id>

Please note: WorldPay will be stated on your debit card statement

This was NOT a live transaction - no money has changed hands

 

at https://select.worldpay.com/wcc/purchase

 

I also get an email, with a very strange content: "you made a payment for GBP 10.00

to Bluelines New Media Solutions Ltd t/as Bluelines New Media for Purchase from <my shop name>."

 

The system is still in test mode, would that matter? (I can't request it be turned live till I know it works). At the momen, no order appears in osCommerce and WorldPay doesn't redirect back to the shop.

 

Any ideas would be appreciated

Link to comment
Share on other sites

Hiya

 

I am having the same problem!! Can anyone tell me how they fixed it? I cant get my head round it. When I log on again the stuff I had in my basket is still there as if I had not checked out. And I cant find the order!

 

I would be very grateful for some advice from anyone who has found a solution. My head is aching now!!!

 

Thanks

 

Angie

Link to comment
Share on other sites

I'm not saying this is the solution. But I had all sorts of probs with this contribution (which are all sorted out now - and were all my fault). Try having a good look @ catalog->includes->configure.php

Make sure that your cookie domain names are set right (without the http://) and everything else in that bit. The contribution it's self is very stable which means that it must be somthing to do with your instalation or configuration.

 

The reason that the order isn't being put in your oscom database is becuase the page that worldpay comes back to is first wpcallback.php which only realy displays the result then that page directs to checkout_proccess.php which is the page that adds updates everything and send confirmation emails etc.

 

Once it works it's very good.

 

Hope this helps a little bit.

 

Nimmit

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...